Loading

Cultivating Spatial Intelligence

ArcMap 101: Collecting GIS Data and Metadata

This introduction to ArcGIS starts with an exploration of the public data repository of the state of Massachusetts. We use this site to understand the context of GIS data in adminstration. The MassGIS site is exemplary in the multitude of datasets that they provide and the quality of their documentation for each dataset (metadata.) We download some datasets and open them in ArcMap. We then explore these data in arcmap: looking at attribute tables and adjusting symbolization and label properties. The relationship between Map Documents, Layers, and Datasets is demonstrqated as we learn how and why to save maps documents and layer files with relative path names, and finally to back up our work on a USB drive. Throughout the tutorial we establish a folder structure for a GIS database that assures that our collection can gro in terms of the numbers od map sources and working documents and even in terms of the numbers of collaborators we may engage with on a project.

Related Documents


The overall path of this tutorial will take us through the following territory:

Part 1: Capturing Data and Metadata

  1. Consider the Purpose of your GIS Project
  2. Discover and Download some GIS Data and Metadata.
  3. Hints for Reliable Filesystems
  4. Understand attributes and properties of GIS datasets.
  5. Understand how layers apply styling to gis data.
  6. Save Maps with Relative Path References
  7. About Saving and Sharing Styling information with Layers
  8. Backing Up your Work

Part 2: Trimming Data and Extending the Collection

  1. Restoring a Collection-in-Progress
  2. Capturing Data and Styling Information from ESRI Streetmap
  3. Managing Data Connections in an ArcMap Document
  4. Managing Data and Metadata in ArcCatalog

Begin with a Purpose

Our objective today is to acquire some data that will help us to understand neighborhoods in Somerville, Massachusetts particularly with regard to the transit system. Our interest is centered around the extension of the Green Line and the potential changes that may be associated with this project. To begin, we will look for some data that will inform our understanding of the cultural and physical setting of somerville neighborhoods.

Strategy for Information Management

We anticipate that our study will take some time. We will end up gathering data from many sources. We will need to keep our work backed up and reconstituted on different computers. The data we are gathering now will serve as a snapshot of the situation before the green line is extended, and therefore and we will want to make sure that our source materials, working files and presentation documents can be shared with successors who can later pick up where we left off and take our work forward. These desires call for us to think strategically about how we organize our sources, working documents and presentation files. For a deeper discussion of this strategy, see Organizing Site Information for Collaboration and Re-Use.


Hunt for Data

The page, Sources of Spatial Data discusses many sources for geographic data. You probably want to look at that later. For now, we will go straight to the excellent web site of the Massachusetts GIS clicking on the link at the top right, to Download Free Data, will be passed through a page that invites us to Read Metadata and Download Data after reading some announcements about coordinate systems. Once on the Layer List Page, it is inspring to see how state government of Massachusetts makes it so easy for people to obtain the information resources that are used to administer and plan public facilities and policies!

Explore Metadata for A few Layers

The MassGIS Layers page allows us to browse through a catalog of data layers and to examine information about each dataset so that we can understand important aspects of the data, such as:

This information is critical for understanding whether a data set is fit for making the arguments and models that we may use it for. Whenever we use the work of other people in our scholarship, we know that we must always provide references, and so it will be important to save this information with the data layers that we download. The technical term for this data about data is Metadata For a deeper discussion of metadata, see Understanding Data, Referencing Systems and Metadata.

Downloading Data and Metadata

The first dataset that we will look at will be the datasets associated with MBTA Rapid Transit, which can be found under the heading, Infrastructure. What time period is represented by this dataset. Who is the primary source that should be credited for the data? Note that the primary source is NOT MassGIS! MassGIS is issuing the data today, and this may be useful to know later, but the agency responsible for the data is the Central Transportation Staff, and the date represented is 2006. This is information we will want to remember. So when we download the data, we will also download the metadata so that we and our successors will be able to use these resources responsibly.

Tips for Reliable Filesystems

  • Ask the Windows file manager not to hide the extensions so that you can see for yourself what sort of files you have. See screenshot
  • Keep your working files on the local hard drive. Working with data on network filesystems or usb drives is not only slower, but also is subject to all sorts of unpredictable behavior which we don't need complicating our lives. Never work on files that are on a USB stick.
  • Begin with a Scalable Directory Structure It is not obvious at the beginning how to keep data organized so that the collection does not grow hopelessly complicated as it grows in terms of sources, and collaborators and working documents. For an in-depth discussion of a time-proven strategy, see Organizing Site Information for Collaboration and Re-Use.
  • Never include Spaces or Special Characters in the names of folders or Datasets. Never begin the name of a folder or dataset with a numeral ArcMap and some of the other tools you will be using are old programs that were developed when there were simpler expectations about what a file or folder could be named. You may be able to get away with breaking these rules for a while, but when you finally encounter a tool that cannot cope with these, it wil leb a huge hassle if you need to rename folders.
  • Save backup copies of your map documents and your entire project as versions. Never use Save, but use Save-As changing the name of map documents to reflect new versions. The same is true of backup archives. Periodically zip your working folder and sources folder append the name to reflect the date that you saved it. This way you can always go back to an earlier version of you find you have made a change that you regret!

Download the MBTA Rapid Transit Datasets and their Metadata

  1. With Windows Explorer, create a folder for our project. Keep your project files near the top level of your hard drive. Create the folder: Computer Local Disk C:\projects\greenline_ext. Within this folder make a subfolder named sources. Within the sources folder create a new folder named massgis_2012. As our collection becomes more diversified, the reason for this folder structure will become clear.
  2. Right-click on the download link at the top-right of the MBTA Rapid Transit page. Save the file into your massgis_2012 folder.
  3. Massgis issues their data as self-extracting zip archives. If you double-click the archive, you can call for it to be expanded into the appropriate folder.
  4. While we are on the MassGIS metadata page, lets use our browser to save the complete web page into the same folder as the data. Doing this now is easy. If we aren;t scrupulous about saving metadata as we gather data, experience tells us, that it will be nearly impossible to understand the essential provenance of the files later.
  5. Use Windows Explorer to take a look at the files we have acquired.

Explore the data in ArcMap

Now for the fun part. We will explore the data as layers using ArcGIS. We will begin by opening ArcMap and exploring the empty interface. Then we will add some laters form the massgis folder and practice some basic moves with the ArcMap interface.

References

Add and Explore some Vector Features and their Attributes

  1. Use File > Add Data to bring up the file browser.
  2. Your C drive will not be visible! In the file browser click the 'Connect to Folder' button, which is a folder icon with a black plus sign on it. Flip open the contents of Computer and choose Local Disk C:
  3. Use the Add Data button to add the following datasets frm the east_mass/gis/massgis folder:
    • GIS.DATA_MBTA_Nodes.shp
    • GIS.DATA_MBTA_Arcs.shp
  4. Use the Zoom and Pan Tools
  5. Use the Information Tool to click on some things to see their attributes.
  6. Right-Click on the MBTA_NODES layer and choose Open Attribute Table. Take a look at the columns.
  7. Use the Measure Tool to measure the distance between a few of the stops.
  8. Click the box at the far left of a row to select a particular station.
  9. Right Click on the Stations layer and Choose Zoom to Layer and see how that selected station is selcted on the map!
  10. Use the Select Tool to select a station from the map, and notice how it is selected in the attribute table!
  11. The Attribute table can be used to explore associations features based on their to their observed attributes. Right Click on the Line attribute for stations and choose Sort Ascending
  12. Now open the attribute table for Subway Lines Take a look at the attributes that distinquish one line from another. What does Grade refer to? How can we find out?

Vector Feature Classes

A Feature Class is a collection of references that are made on objects of the same type or class. So in the MBTA_NODES dataset, all of the features seem to be subway stations. Each station is represented by a point that references its location, and a couple of fields that store references to the Name of the stop and the transit line that it is on. That is easy enough? Are T stops actually points? No. Is this dataset good a good-enough representation of T stops for our purposes? Maybe. Explore the attribute tables for the other layers.

The attributes of a feature in a vector feature class can be points or lines or polygons. This two-dimensional geometry is stored in the table, just like numerical refernces (e.g. areas) or dates or plain character strings. In GIS, geometry is just another type of a data field.

Layers Control the Portrayal of Datasets

GIS Data provide a means of organizing information about entities that have been observed or measured. The entities themselves are represented as collections of attributes. There two basic ways of organizing such observations in GIS. Vector data represent distinct entities as rows in tables that employ various types of referencing systems, including geometric shapes (Points, Lines and Polygons), along with attributes of these things, as numbers, text strings and dates. Raster datasets use regular arrangements of cells that represent measurements or observations of locations. Each of these types of references has its own sort of logic that we can use to understand and compare the observations that have been made.

References

Working with Layer Properties

  1. Double-Click the MBTA_Arcs layer to bring up its properties
  2. Go to the Symbology Tab and choose Categories->Unique as your category mode. Follow the instructions in the reference provided above to color the lines according to the value in the attribute field Line click each symbol in the legend editor to color the lines apropriately.
  3. Make a copy of the MBTA_ARCS layer by right-clicking it and choosing Copy.
  4. Now paste it, by right clicking the Data Frame where it says "Layers" where you would choose Paste Layers.
  5. Now you can make a new layer based on the attribute, Grade.
  6. Now open the properties of the MBTA Nodes Layer. And set the Label Properties to use the Station attribute to label each stop.
  7. Having closed the properties dialog, you can now turn the stop labels on and off by right-clicking the layer and checking and un-checking "Label Features."
  8. Now lets fix the names of these layers so that thay make intuitive sense. Long-click on the names of the layers in the table of contents and change the names of the layers to "MBTA Lines" and "MBTA Stops" respectively.
  9. Check the properties of the layers and see that even though the layers are renamed, each is still referencing the old dataset in the east_mass\mbta folder.
  10. Create a group layer by right-clicking the data frame and choosing the group layer option. Rename this new group layer: MBTA System. and drag your new MBTA layers into this.

So now you see the functions of vector datsasets and layers. A layer is actually a form of metadata that provides styling or portrayal instructions for a dataset. Any dataset may have any numbers of layers. The layer properties identify the dataset that the layer references. Often, a layer's source properties become out of sync with where the data are. Actually this happens quite often. When this happens, the layer will show up with Red Exclamation Marks and this can be fixed, by looking at the source properties to see what dataset was refernced by the layer, and then fixing the data source options. This can either be done from within the layer properties or by clicking on the red exclamation mark.

Save Your Map with Relative Path References

We have spent several minutes developing portrayals and legends for the MBTA Stations and Lines Lines by Color and by Grade Relationship. There are a couple of ways that we can save these so that we can re-use them later. The first option is to simply save the ArcMap document (an .mxd file.). Before saving our map, we ought to think a little about our folder structure. We have started one branch of our folder tree for sources. Within this branch of the tree, the names of folders help us to understand where datasets came from. Now we are about to save some work that has originated with us. Our map, for example may reference data from many sources. Where should we save this? You may think it peculiar to be worrying so much about folder structure when our project is so simple. But the point is that we know that the project is going to get more complicated. The tragedy we are trying to avoid is that, because of the way that map documents and layer s reference data, re-arranging the folders after the project gets complicated is a very difficult and costly thing to do. The folder structure we are learning here is designed so that it can gro and grow in terms of the mumbers of sources and the numbers of collaborators without growing substantially more complicated as it grows in size. For more information on this structure, you can consult organizing Site Data for Re-Use

References

Saving Your ArcMap Document

  1. In your projects/greenline_ext folder, create a new subfolder named work_pbc instead of pbc use your own initials! this folder will be where you can keep your working documents. Your working documents will reference data in the sources folder. You may be joined by other collaborators who can add their own work folder to this project, and both of you will be able to create documents that reference the same source tree.
  2. Over the course of the project, you may create several different types of working documents. We won't want our work folder to become a mess, so we will take this opportunity to create an arcmap folder inside.
  3. Now, back in ArcMap, we will use File->Save As to save our map document in your work/arcmap folder.

Congratulations, you can now quit arcmap and re-open the map document and recover your work! But think about this: The layers in your map document refeence datasets in the c:\projects\greenline_ext sources folder. What if your collaborator has his greenline_ext project on his external hard drive that is recofnized as drive F:\? If your map document is referencing its data with absolute path names, this would effectively break the references between the map layers and the data. This would amount to little ! Red Exclamation Marks. Indicating that the source for the layer needs to be reset. This can be fixed, as described in the ArcMap On-Line Help. But it is better to simply adjust the map document properties to use relative path names as described below.

Saving Your ArcMap Document with Relative Path Names

  1. Quit Arcmap
  2. Change the name of the the greenline_ext folder to greenline_ext2. This is not really necessary, but will familiarize you with the symptoms that occur when absolute path references are broken.
  3. Now, double-click on your aremap document to open it.
  4. Observe that all of your layers have ! Red Exclamation Marks.
  5. Go to one of the layers and bring up its properties and examine the Source properties. Note that Arcmap is looking for the data source in the old location, which does not exist any more. Note the name of the shape file that is being referenecd. Close the properties dialog.
  6. Now click on one of the ! Red Exclamation Marks. And in the Find-File dialog that pops up, find the shape fiole in its new location.
  7. Having completed the above step, you should now see that all of the path references have been healed.
  8. Now to make sure that those bad ! Red Exclamation Marks do not occur: Go to File->Document Properties and check the box near the bottom of the page to reference data using relative pathnames. You should always check this since for some reason ESRI has made absolute path names the default setting for some reason.
  9. Now save your map again.

Now, as long as the you keep the folders within your greenline_ext folder all together, and don;t rename the sources folder, you have a great deal of flexibility fo moving this project around. And this you may do, especially when more than one person is involved in the work.

Saving Layer Files

Saving the map document is one way to save and share the styling information that you create to display data in meaningful ways. But what if you had an existing map and wanted to import just a few layers, with ready-made styling information. The way to do this is to save the layer as a .lyr file. This lyr file can then be passed around and opened up in any map document.

References

Saving a Layer File

  1. Right-Click on your MBTA group layer and choose Save as Layer File.
  2. While saving this, create a new folder, work/arcmap/lyr_files for this sort of thing, and sabe your layer file in there, this is where you and your collaborators wil lknow where to look for the custom portrayals that you have made.
  3. Remember that there was a .lyr file in that came with the stuff we downloaded from MassGIS. Why fon;t you go ahead aand use your add data button to load that. Amazing, eh? For Extra Credit, figure out how those custom T stop symbold were made.

Get More Data and Layers

So, now we understand a lot about layers and map documents. We are crossing the frontier into the domain of data wranglers!! But a map of the MBTA subway system is pointless without some context. So lets go back to massgis and download several more layers:

To save time, I have already downloaded all of this and wrapped it up a s single zip archive you can download here. Once downloaded, you can just double-click into this zip archive, and copy the contents into your massgis_2012 folder.

You know what to do now.

More Fun with Layers

  1. Go ahead and add the layers for USGS_Hydro_25k.lyr, OpenSpacePrim_Purp.lyr, and MA_Towns_Shaded_Group.lyr.
  2. Adjust the drawing order of the layers (by dragging them up and down) so that you can see them all.
  3. Inspect the way that the legend names have been assigned using the Symbology Properties for a couple of the layers.
  4. Note that the Hydrography layers dissappear when you are zoomed in.
  5. Take a look at the General properties of these layars and see how you can click the option to Show Layer at All Scales
  6. Save your map.

Backing Up and Sharing Your Work

OK, thats enough for one workshop. We're ready to quit, but we don;t want to leave our work on a public lab computer. e know that it wil lbe wiped out as soon as the machine is shut down. And this is actually a good assumptioon to make on any computer. if you expect problems, you will seldome be dissapointed!!. So lets back up our work to a USB stick or a portable hard drive. In fact, I personally believe that y7ou really aren;t backed up unless your work is copied to two different devices. So I always carry two USB sticks. Another tip I will share with you, is that before backing up, you should compress your data collection to a zip archive, and then date this archive so that as your project progresses, you wil lbe able to see which backup is your latest one. This routine will also let you see on all of your different computers (and collaborator's computers) whether you have the latest version of the dataset. Because the files are all packaged, if you follow this routine religiously, you will have confidence that you can wipe out the old working copy on any computer and simpy unpack the later one, without worrying about losing work that may have been done in the older archive.

Back Up and Go Home

  1. Save your map document one more time
  2. Quit ArcMap
  3. In Windows Explorer, right-click your greenline_ext folder and choose Send To > Compressed Zipped Folder.
  4. Long-Click on the resulting zipped folder and append today's date to the name. (e.g. greenline_ext_1_25_2012.zip).
  5. Copy the zip file to two different drives that you control
  6. Log out and relax knowing that all of your valuable work is safe!


Part 2: Trimming and Expanding the Collection

The idea behind the second part of this tutorial is to see how our collection effort may be resumed, articulated, and extended. Reviewing our goals from the first part, we are reminded that our study regards the MBTA transit system and in particular, how it relates to the city of Somerville. This objective provides some idea of what the extent of our maps and models will need to be. We know that we will be expanding our data collection in terms of the numbers of datasets, but we want to keep it concise in terms of the extent. Our desire is to create an easy-to-use laboratory for studying a fairly limited area. We don't want to burden ourselves and our collaborators and sucessors with detailed representationa of every park and pond in Massachusetts. So part of this tutorial will be oriented toward understanding how we can use arcmap to trim our data to a manageble extent.

Next, we will discover a very useful data collection -- the ESRI Streetmap data -- which has several very useful datasets covering the entire united states. Streetmap also includes some very sophisticated layers in terms of symbology and labeling. We will apply what we have learned about layers to capture useful data and styling information from ESRI stretmap into our collection. In so doing we will also see how the collection is extended by adding new source folders. We will also learn about a new way of attaching metadata to datasets.


Restoring our Collection-in-Progress

The first thing we will do is return to our c:\project folder. We will restore our last updated archive and open the map document that we saved from last week.

Restore the Collection from Last Week

  1. Download The zipped archive that we saved at the end of part 1.
  2. If you had a zip archive of this project existing in your projects folder, you would check the dates to see which one was newer.
  3. Right-click the archive and choose Expand All.
  4. The archive contains a folder named greenline_ext so you want to expand this directly into the projects folder. To do thei remove the reference to the dated folder before extracting See picture
  5. Look inside your extracted folder, Your projects folder should include a folder named greenline_ext, and within it, folders named work and sources. If you have a folder named greenline_ext with another greenline_ext folder inside of it, delete everytning and return to the previous step.
  6. Click into the folder work/arcmap/map_docs and double-click the file compilation.mxd to get to where we ended up last week.

Inspect and Streamline our Data Compilation

The first thing you should notice about our zip archive is that it is over 100 megabytes in size. You will also notice that the map takes an awful long time to draw. To understand why this is, right-click your Protected Openspace layer and choose Zoom to Layer. Now it becomes clear that we have detailed representations of every park and pond in the state of Massachusetts. This is unnecessary, since we are focused on the Boston metropolitan area. Carrying around all of this extra data will cost us a lot of aggravation waiting for maps to draw and for files to copy and so on. So its time to leatn how to streamline our data so that we will have a nice, concise laboratory that will allow us to make maps and experiment with models with a minimum of headaches. Streamlining oue collection will call on our understanding of Layers and how they relate to Feature Classes. It will also introduce a new technique of Exporting Data from a Layer.

References

Exporting a Subset of Features

  1. Zoom to an area that you feel will cover the context area for your study. Remember that it is better to be a little to large than to be too small. For our study, we will zoom to an area that incoudes all of the towns that are touched by the MBTA system and all of the towns that share a border with Somerville. Zoom in to this area.
  2. Right-click the Protected Openspace layer, and examine its Source Property
  3. Now, Right-click your Protected Openspace layer, and choose Data > Export Data
  4. In the Export Data dialog, adjust the Export: pulldown to choose Export Features Within View Extent. Leave the default option to Use the Source Data Coordinate System
  5. Push the browse button to the right of the Output Feature Class slot. Navigate to your projects/greenline_ext/sources/massgis_2012 folder. Click the name of the original source for the layer, openspace_poly.shp. For the name of the new clipped dataset, change this name to openspace_poly_cl.shp. Click Save to get back to the Export dialog.
  6. Now click OK to export the features with the curent view.
  7. When asked, say OK to adding the new feature class to your map.

You have now created a new shape file, which is a subset of the ferature in your original dataset. Whay you will notice is that the new features do noty have any of the styling of the layer we started with. Why not? Because, as we learned last week, datasets in arcmap are not born with styling information. Portrayal information is added through setting the layer properties. We can use what we know about layers to quickly assign the properties of our state-wide Protected Openspace Layer to reference our new dataset.

References

Changing the Source Reference for a Layer

  1. Double-Click your Protected Open Space layer to bring up its proerties dialog.
  2. In the Source tab, click Set Data Source and set the source for this layer to match your new clipped layer.

Exercise: Capturing Data and Layers from ESRI Streetmap

Up until now, this tutorial has focused on data from MassGIS. Which is quite good. But if your study area is not in Massachusetts, we need to find some other data. Next we will apply what we have learned so far, to gather some data from the very nice collection of styled GIS data that ships on DVDs with the ArcMap software. At the Graduate School of Design, these datasets will be found in the shared folder goliath:\public\geo\esri_data_10\streetmap_na. If you look into this folder with Windows Explorer, you will see that it contains a .lyr file and an .mxd file and a bunch of data that is stored in a file format that used a .sdc file sufix. According to Wilipedia, SDC is a proprietary compressed file format that is controlled by ESRI. Its worth noting that each sdc file also has an associated xml file, which contains its metadata (which we will explore later.) For now, lets just add the layer file to arcmap.

Add the ESRI Streetmap Group Layer to ArcMap

  1. For dramatic effect, zoom turn off all of the layers in your map fils.
  2. This should be second nature by now... Use the add Data button.
  3. You may noot see your Goliath shared drive in your Folder Connections thing. As before, you need to use the Connect to Folder button at the top-right of the Add Data dialog (a folder with a black plus-sign icon) to add the geo folder to your catalog.
  4. and finally, you can add the layer file, ESRI_Streetmap_North_America_2010.lyr
  5. When this layer adds you will see that you have a lot of nicely styled GIS data for our study area
  6. Flip open the transportation group layer and the sub-group layer for roads. Note that all of the layers are scale-dependent.
  7. Zoom way out to see all of massachusetts. Zoom back in to the Boston Metro Area.
  8. Note the fancy treatment of the highway labels (shields, etc.). Take a look at how these different symbols are applied to different subsets of roads in the layer' s label properties. We want this, but we don;t want to have to copy all of the roads in the united states. We want t anice, concise portrayal of major roads for our context map, and maybe we also want a layer of all of the roads for a smaller area that covers somerville.
  9. While you are on looking at the properties for your major roads layer, make a note of the name of the data source
  10. Use what you learned in the preceding parts of this tutorial to export a subset of the streets and then adjust the Layer Source Property of the orignal streetmap layer to point to the new smaller dataset.
  11. Its a good idea to save the layers for data you have captured from streetmap, to .lyr files in your streetmap folder.

The scale dependent view properties of these layers are somethign you wilo have to deal with. As you already leaqrned, they can be set for eachlater, under the layer's General proerties. Or you can adjust them by right-clicking and chooding options under Visibility Some of the most useful data in the ESRI Streetmap data are the detailed streets. You will notice that several of the layers at the bottom end of the Streets group layer in streetmap reference the same data source. So you need not download more than one of these.


Managing the Data Connections in a Map Document

Now its time to clean up the map document. We have a bumnch of layers from ESRi Streetmap that are still referencing data on the Goliath server. Remember, that we are creating our data collection so that it can be easily be exchanged and re-used by others later. All of the data that we are usiong must be within our easily archivable project folder. Before saving our map and wrapping up this phase of work, we want to make sure that the map diers not reference any data that is not within our projects/greenline_ext folder. As it happens, the ArcMap table of contents can be switched to show you the file system location for each of the data sources referenced by your map. We will use this mode to remove any layers that are referencing data outside of the map.

References

Cleaning Up References in your Map

  1. Click the second icon from the left at teh top of the arcmap table of contents to re-order the layers of your map by Source View.
  2. Make sure that the layers you want to preserve are within the c:\projects\greenline_ext folder.
  3. Use the minus signs next to the source headings to simplify the view.
  4. Right-Click and delete all references to the Goliath server.
  5. Go to File > Map Document Properties and make sure that your map document is still storing references to data sources using Relative Path References
  6. Save Your Map

Congratulations: you now understand how to take data fro the wild and to shape it and organize it for your purposes. In short, you are becoming a data wrangler!! There are just a couple of additional things you need to know.


Managing Data and Metadata With ArcCatalog

One thing we must remember before we close up our project is that we still have some of the un-clipped datasets in our massgis folder. We also need to figure out what to do about the metadata for the layers we captured from Streetmap. This wil provide us an opportunity to look at another facet of ArcMap -- The Catalog Window is a special file explorer, that is especially for looking at geographic data.

References

Exploring Metadata with ArcCatalog

One of the more imporant developments in GIS over the past few years is that data providers have been doing a better job of creating standardized metadata. IN the United States, the most common metadata standard is the Federal Geographic Data Committee (FGDC) Content Standard for Geospatial Metadata. In the rest of the world, the most common standard is known as ISO19115. ArcMap is hep to all of this and as we will see, if a dataset has metadata, ArcMap will keep track of this and even update the metadata as we do things to the data. We can also use ArcMap to create and edit formal metadata. This can be accomplished using the Catalog window.

One fly in the oinment here is that the original release of ArcMap Release 10 has a bug or two that interferes with this metadata capability. This can mess up our demonstrations in the computer lab, which nave not been patched. If your ArcMap is patched with Servicepack 3 (available on our software server) you will see how cool this is. Otherwise, save your map, because fooling around with the following steps may cause a crash!.

References

Explore Metadata in the Catalog Window

  1. Click the little yellow file-cabinet icon near the middle of the arcmap tool-ribbon to open the Catalog Window.
  2. Note that teh Folder Connections we have made appear in this file browser
  3. Find your way to our greenline_ext/sources folder.
  4. If you don't see the streetmap folder, right-click on the sources folder and choose Refresh.
  5. Within the streetmap folder, shoose your new Roads layer, right-click it and choose Item Description. Up pops some simple metadata. This is not quite as deepa as what is required by the FGDC.
  6. IN the ArcMap menu bar, choose Customize > ArcMap Options > Metadata and change your Metadata Style to FGDC CSDGM
  7. Look at the Item Description again.
  8. In the top left of the item description, click the Edit Tab
  9. This is really cool!

Note 1 It is still fairly rare that data comes with formal metadata, so don;t count on it. It is still up to you to make sure that you capture whatever metadata you can when gathering data.

Note 2: You also should be able to access the View Item Desscription option by right-clicking a layer in the table of contents. But this is one of those things that will crash ArcMap if you aren;t patched up to the current service pack.

Using ArcCatalog to Manage Data

We are now ready to clean up our data collection. We could use windows explorer to order our data files by name and to select and delete some of ther datasets we have gathered but aren't using. To do this, we would have to be careful that we select all of the files that are part of a shape file, and walso that we don't accidentally delete a file that is involved in some other datasets. Renaming a shapefile or some other type of data can be particularly hard. Working with certain types of data, particularly the ArcInfo GRID and Coverage and Geodatabase type datasets, trying to manage data with Windows will certainly mess things up beyond repair.

Delete your Unclipped MassGIS Data

  1. Use the Catalog window to go into your MassGIS folder.
  2. Find the unclipped openspace layers
  3. Right-click and delete them

Note: The catalog window won;t let you delete a dataset if it is open in ArcMap or any other application. SOmetimes this even applies if the folder is open in Windows Explorer. Sometimes ArcCatalog will refuse to rename or delet a dataset even if it thinks it is open, when it actually isn't. The only thing to do when this happens is to quit ArcMap and all ESRi software and try again. If you want to manage data without ArcMap open, you can run ArcCatalog on its own by selecting it from the ArcGIS program group in your Start menu.


-->