[an error occurred while processing this directive]   Computer Resources GIS Manual  

form Z 101 Modeling and Siting a Baseball Field

This basic form-Z exercise demonstrates many of the fundamental principles of representing the world with computer aided design (CAD). We start with a specific representation problem -- to have a team of people experimenting with configurations for a metropolitan sports center to be located at fields point, Providence, Rhode Island. We will have to site some baseball fields, and maybe tennis or basketball courts, football and/or soccer fields.

We have the basic capabilities of CAD: -- to create representations of three-dimensionnal objects with precision drafting aids; to organize objects with color and layers and files, to work with georeferenced imagery and to replicate and create instances of prototype representations. These tools permit us to quickly model and compare various scenarios on a real site, and to share drawing and scenario components with our colleaques.

Tool Referencing Conventions: THe FormZ interface is a maze of nested fly-outs buttons, and options panels. For a beginner, it isn't obvious where a tool will be found just by its name. In these tutorials we will use the tool-referencing system invented by Lachmi Khemlani in her book, FormZ 4 Thus, when referring to the third pick from the 8th flyout of the Window tool palette, we will simply say W-Tool:8,3 As pictured here.. The modeling tool palette has 2 columns, so a reference such as M-Tool:5b,1 refers to the first pick from the second column of the fifth flyout of the Modeling toolbar, As pictured here.. Whenever we reference menus from the main menu-bar we will refer to them as Menu->Item, thus, Edit-Cut refers to the cut item from the edit menu As pictured here.. Of course, these conventions assume that you haven't customized form-Z's menus. If you suspect that your menus may have been fooled with, you can always reset them to the defaults with the General System Preferences under Edit->Preferences.

References and Resources


Think about your modeling Goals

The first step in every modeling project should be to think about your goals for representing objects. Thinking about your goals in advance will:

  • Help you to avoid wasting time on aspects of your model that are unimportant
  • Add features to your model that will make it better suited to your goal (perhaps more versatile)
  • A pre-stated goal will provide the basis for evaluating the model after we make it. Since we want to be critical users and consumers of CAD models, we will be getting practice at evaluation in every lab assignment!
In this case, we need a prototype of a baseball field so that we can make some siting decisions. Our prototype will be used to establish the size of a baseball park footprint. It will be helpful if the ballpark has the iconic look of a baseball field so that people will be able to tell what it is at a glance, but it need not be photo-realistic. We want our prototype facilitate the modeling of lots of different scenarios, and we want to be able to share it among several models being worked on by others. Also, our model is bsing used to introduce CAD concepts, so we may spend some time modeling the bass and the pitchers mound, just for fun.

The bases are arranged on a square, 90 feet on a side

Laying out the diamond will get us acquainted with a couple of CAD fundamentals:

  • Setting up the project units
  • Precision drafting with grid snaps.
  • Saving projects
  • Naming, Pre-Picking, Post-Picking, Querying and adjusting objects.

Our first task is to open a new FormZ project, and set up its units. We anticipate that our dimensions will be in Her Majesty's feet and inches, and that we will be integrating with GIS data, so we will set up our coordinates as pictured here.

We begin by laying out the base lines, a square upon which the Home Plate and the three bases are set. Drawing squares and other 2d features involves learning about the drawing tools and the modifier tools in form-Z. This is dealt with in depth in the form-Z tutorial. see page 25..

It is easy to make a rectangle. Make sure you have the Rectangle Tool, M-Tool:3a,1 and the 2D Surface Modifier M-Tool:2a,1 picked. Make some random boxes and then pressing backspace, or ctl-z, or Edit->Undo to delete them. Watch the prompts window at the bottom left of the formZ screen. It is tracking your mouse movenets and entering coordinates at the prompts.

To make a square precisely 90 meters on a side will be a good reason to explore some of the precision drafting aids available in all CAD packages:

Grid Snaps: It is difficult to put your mouse exactly on (90,90,0) isn't it? Right now, our drawing has a resolution down to the inch. Our life would be simpler if we could make out mouse snap to even increments of 10 feet. This is accomplished with the use of grid snaps. For more on grid snaps, see Pages 22 and 41 of the formZ tutorial.

While we are exploring grid snaps, we will have to learn about some of the idiosyncracies of form-Z. TO set up the Grid, we have to bring up the Window Setup Dialog (under the Window menu) to adjust the major and minor grid cell size. For the baseball field, it will be useful to set the module to 50' with 5 grid divisions per module.

Next we have to set up the Grid Snap options, by double-clicking on the grid-snap toggle, W-Tool:4 and setting the grid module for snapping to 10 feet.

Now to turn on grid-snapping, click the gridsnap toggle so that it is shaded.

Make a rectangle with one corner at 0,0,0 and the other at 90,90,0.

Now to see our work, we need to look at some of the window tools, especially the ones for panning and zooming, W-Tool:7. These are covered in the tutorial on pages 11 and 12.

  1. Use the various pan and zoom tools. Finally, use the zoom extents tool to get your baseball diamond to display in the window.

Now before we forget, lets save the file to a folder on our local hard drive. You will want to get in the habit of saving your work each time you finish something that is worth keeping. While we are on the subject, here are some rules to live by when building things with computers:

  • Never write over your old files with 'Save.' Always create new incremental versions with 'Save As', leaving your old versions in case your working copy becomes corrupt.
  • Always keep your working projects on the local hard drive. Network disks, CDs, Zip Disks, etc are flakey. These other media are OK to copy to and for backups, but not for actually working from.
  • In form-Z the default behavior of the save button is to eliminate your undo queue, you may want to use 'File->Undo Options' to save the last 20 operations and uncheck 'Reset after saving project'
  • Always back up your work to a CDROM after each session. Alternate CDs each time you back up.

You have just created the first object in your model of a baseball park! Lets take a look at some of the things that you can do with objects.

The Object Pallette The object pallete is discussed on page 2-80 of the Interfaces manual. It is sometimes useful to keep your objects neatly named and organized so that you can access them from here. Change the name of your latest object to 'Baselines' by clicking on it here. You can access more information about objects, and manipulate them by clicking on the 'Name' field in the Objects Palette.

Click the check-box next to the baselines object. Notice that your box turns red. You have just Picked it. Uncheck the box, or click on the very top of the check-mark column. This is a handy way to select and de-select objects!

Picking and unpicking objects and parts of objects: Picking objects and their parts in form-Z is something you do all the time, and perhaps not so intutitive. There is a section on picking in the tutorial on Pages 53-60. Like the draw tool, the pick tool, M-Tool:4b,1 has a modifier -- the Topological level tool, M-Tool:4a. With the topological level set to 'Object' select the picker tool, and click on part of the baselines object. It should turn red. Now unpick the object by clicking with the picker tool in a blank part of the window. Try picking different parts of the rectangle by chosing different topological levels.

Tool Options: Notice when the pick tool is selected, there is a palette of Pick Options evident at the top right corner of your Form-Z window. Depending on what tool you pick, tool-specific options may be displayed here. The full meaning of all of these options is covered only in the Form-Z User manuals.

Querying Objects It is very useful to be able to manipulate parts of objects. This is covered in the turorial on Page 219. For example, we can query and change the parameters of a single vertex of our rectangle.

  1. First, unselect all objects by clicking on an empty part of your drawing.
  2. Then set the Topological modifier to point
  3. Select the Query Objects tool, M-Tool:12b,1.
  4. Look at the prompts window for instructions.
  5. Click on a vertex of your rectangle.
  6. Notice that you are offered a dialog that lets you modify all of the parameters of the point (its coordinates).

Prepicking, Postpicking and the Prompts Window: Form-Z has an odd convention for selecting things that can be confusing to people who grew up using other packages. Sometimes your actions with various tools don't do what you expect. It is always helpful to look at the Prompts Palette after choosing a new tool to see what form-Z expects you to do next.

For example, try this:

  1. Unselect all objects
  2. Select a point using the Picker tool.
  3. Then use the Query Objects tool to click on another point.
  4. Notice that the coordinates that are displayed are not those of the point you clicked on with the tool. They are the coordinates of the point that was selected when you chose the Query Objects tool!

Form-Z queried the coordinates of the point that was Pre-Picked Repeat steps 1 through 3 above, but watch the prompts. You will see that the actual location of the second click is not important. Form-Z assumes that you want to query the pre-picked point, and the second click merely activates the query. Believe it or not, this sort of clicking syntax is useful when you want to do something to several picked objects at once. When things don't seem to be happening the way you expect, always check the prompts palette.

Now try the Post-Pick method:

  1. Unselect all objects
  2. Choose the Query Objects tool.
  3. Look at the prompts
  4. Now you can choose the object you want to edit.

If you modified the location of any of your vertices in the last exercise, you should Undo or Revert to Saved (under the edit menu) at this point.

Getting on First

From our source of field dimensions,


First, second and third bases shall be marked by white canvas bag, securely 
attached to the ground. The first and third base bags shall be entirely within 
the infield. The second base bag shall be centered on second base The bags shall be 
15 inches square...
Making first base will provide us with experience with these additional CAD fundamentals:
  • Precision drafting with typed-in coordinates and object snaps
  • Moving and copying objects
  • Using object snaps
  • Working with three-dimensional views
  • Creating three-dimensional objects

Precision Drafting with Numeric Input: The first challenge is to make a box 15 inches square. We could set the grid and snapping options down to an inch, but we will try typing into the prompts window instead. Drawing with Numeric Input is covered in the tutorial on page 37. We will first experiment with using numeric input using Absolute Coordinates then we will try using Relative coordinates.

Making a box by typing absolute coordinates

  1. Set your view to Plan View by selecting Views->Top.
  2. Select the rectangle tool and the 2D Surface modifier as you did before.
  3. Now go to the prompts palette and enter 0,0,0 for the first point. Then press the return key, and enter 15",15",0 for the second corner.
  4. Take a look at your new box, and then press control-Z to delete it.

Entering absolute coordinates at the prompts is easy, until your coordinates get too unwieldy to type, as they will when we start working with real map coordinates. The next technique will let us use a combination of mouse-tracked graphical input with relative coordinates to make a box of a certain size right where we want it.

Making a box using a combination of clicks and relative coordinates

  1. Select the rectangle tool and the 2D Surface modifier as you did before.
  2. Now click at the lower-right corner of your baselines square to enter 90,0,0 as your first point. (assuming you have Grid Snaps turned on.)
  3. Now, bring your mouse down to the prompts pallete (ignore the fact that your box is rubber-banding along with your mouse movements) at the right-hand side of the prompts window the prompts window uncheck the box next to the T and next to the A. This turns off mouse tracking and flips the coordinate input for the second point to be relative to your first point.
  4. Enter -15",15,0 for the second point of your rectangle.
  5. Name this object "First Base"

Moving Objects: It seems that no matter how careful you are, you always need to adjust the position of things. In our case, we need to move first base so that the middle of the base is aligned with the second-base line, as pictured pictured here.

There are lots of ways to move objects in form-Z. These are all typical of CAD packages in general. We will experiment with free-form movement and then precision movement with object snaps.

Random Moves:

  1. Turn off grid snaps
  2. Pre-Pick your first-base object.
  3. Select the Move tool M-Tool:13,a1
  4. Look at the prompts window for instructions and choose the point to move from.
  5. Then choose the point to move to.
  6. Play with this until you get the idea.

A person can make precision moves by typing input into the the prompts palette, as explained on page 74 of the tutorial. In our case, when we want to place a particular part of our object -- the middle of the bottom edge -- onto a certain part of another object, the intersection of the first and second baselines, we will have a classic application of:

Precision Movements with Object Snaps:

  1. Turn off grid snaps
  2. Pre-Pick your first-base object.
  3. Select the Move tool M-Tool:13,a1
  4. Look at the prompts window for instructions and choose the point to move from.
  5. Turn on the Object Snap, Snap to Midpoint, W-Tool:6,4 to select the exact coordinates of the midpoint of the bottom edge of first base.
  6. Then use the Object-Snaps, Snap to Intersection Tool, W-Tool:6,9
  7. Then choose the lower-right corner of your baseline square to snap in its exact coordinates to the prompts palette.
  8. First Base moves exactly where it should go!
  9. Play with the other object snaps until you get the idea. You can observe the behavior of the snap options without moving anything by observing the behavior of the coordinate window.

Getting on Second Base with 3D Objects

According to our source for field dimensions, The bags (bases) shall be 15 inches square, not less than three nor more than five inches thick, and filled with soft material.

Making second and third bases will introduce the following CAD concepts through the form-Z interface:

  • Setting view and display settings pages 38 and 42
  • Deriving 3d shapes from 2d lines page 76
  • Generating 3D extrusions page 39
  • Creating parametric 3D primitives Page 44
  • Making copies of objects Page 71

We will start by deriving an extruded object from our humble two-dimensional first base. The tutorial goes into depth about the variety pf 3d solids that can be derived from 2D shapes. We will simply use the Derive 3d Extrusion tool, M-Tool:5a,4 But first, we should adjust our view so that we can see our new 3d shape.

  1. Use "Views->Z=30 x=60" to set the view to a classic axonometric view.
  2. Use the window zoom and pan tools to get a good view of first base.
  3. Select the Derive 3d Extrusion tool, M-Tool:5a,4 and look at your prompts pallete for instructions
  4. Click on first base and watch the extrusion!

You probably noticed that first base was extruded more than 5 inches. The height used in extrusions can be picked or set using the Heights menu.

  1. Undo your last extrusion.
  2. Use Heights->Custom to set a height to 5".
  3. Repeat your extrusion
  4. Make sure grid-snap is off.
  5. Choose Heights-Graphic/Keyed in.
  6. Click on first base and drag its extrusion up and down then click again
  7. If the command keeps extruding, hit the escape key (upper left on your keyboard.) The escape key aborts most commands.
  8. Choose whatever option you want to get your first base extruded to 5"

Introducing Ghosted Objects: Take a look at your object palette now. YOu should have your Base Lines object and your First Base object and a new object. Depending on what you have been doing, you may have lots of other objects, too. Select the newest (last) object in the object palette by clicking the check-mark next to its entry. You will see by the red highlight that the latest object is your extrusion. First Base is still there, but the little circle next to it has turned hollow. THis means that it is Ghosted. This means that the object is not selectable and not an attraction for snapping, and it is symbolized with in a fainter color. Ghosting objects is very useful when you are trying to select or move something else that is vaey close to it. You can unghost an object by clickin the circle through its three modes, On, Ghosted and Off. YOu can also unghost other objects using the Unghost tool, M-Tool:14b,2. The other small icons to the left of the entries in the Objects and Layers palettes allow you to lock objects and turn off their snapping. For more information about these modes, look at the turorial on Page 78 and 214.

Operators and Operands These are terms that you will encounter in the formal logic of CAD. When an existing object is transformed, as we did in extruding our 2d first base, the original form is called the Operand and the transformation is know as the Operator. If you want to make things simpler, you can adjust the Tool Options for the Extrude Operator, to delete the operand when finished extruding rather than ghosting it. This is discussed on page 78 of the tutorial.

  1. Pick and Delete each of the objects except for Base Lines, and the extruded first base.
  2. Change the name of the extruded first base to "First Base"

As your models get complicated, you will learn that the sloppier your objects and layers get, the more you suffer from bad luck and lost work.

Playing with Displays and Views: Now that we have a 3-do object, we can experiment with the different types of display options. These are discussed in the tutorial on Page 42. It is useful and fun to interacively roll the view parameters around with the Set View Tool, W-Tool:8,1 to get the full effect of each view setting. If you happen to be zoomed in, and your Set View tool seems to have to profound an effect, try double-clicking it to change the way that it centers the rotation. Also note that for each Display option, you can hold down Ctl-Shift when choosing it from the menu to get a huge palette of options, which are all discussed in the RenderZone/RadioZity manual. YOu will find that drafting in 3d using a flat computer monitor will require you to use many views to make surt that things are in the right place. It is especially easy to forget the third dimension when snapping to objects that arren't on the correct plane. (For help with this particular 3d snapping issue see the documentation on the Snap Options dialog box in the Interfaces Manual.)

  1. Play with the Display options and Set View tool.

Querying Attributes of Extruded Solids Extrusion is a simple concept that is applied to any 2d face. If you query the attributes of your extruded object, and select 'Edit', you will see that you can always edit the height parameter of an extruded object.

Creating extruded solids directly using the polygon tool and the extruded solid modifier: Extruded solids can be created directly with any of the Polygon Drawing tools, M-Tool:3a, by setting the Object Type modifier to Extruded Solid, M-Tool:2a,3. This is not much different from deriving an exgtrusion except that no ghost is created.

Parametric Solids: As we saw above, the extrusion operator applies a numeric parameter to any planar object. The tools found in M-Tool:1a make solid objects which are based solely on numeric parameters. Click on the Cube tool, M-Tool:1a1, and look at the tool options on the upper-right corner of your window. Notice that you now have the option of simply typing in the parameterrs for a rectangular solid. Later you can edit these parameters using the query tool.

  1. Set the cube parameters to 15",15",5" and click on the screen.
  2. Use a center snap to put second base on the upper-right corner of your baselines
  3. Use the rotate tool, Mtool:13a,2 to rotate it 45 degrees. Just as a reminder, when learning a new tool, you should just check the tool options and the prompts palette, and you are on your own!
  4. Now, go for third!!!

To make third base, we will introduce the idea of copying. We will use the "self-copy 1" modifier, M-Tool:12a,2 to put our move tool into "Self-Copy 1" mode. Then when we move the base, we will move a copy. The Self-Copy modifier is very useful. By setting this modifier different ways you can copy things into regular patterns, and other useful ways, as is brilliantly demonstrated in the tutorial on page 71.

Moving a copy

  1. Put form Z into "Pick Object" mode.
  2. Put your transform tool into "Self-copy 1" mode by selecting M-Tool:12a,2.
  3. Turn on corner snaps.
  4. Make sure that nothing is picked
  5. Choose the move tool.
  6. Click one of the bottom corners of second base, and move it from its position, and click to drop it.
  7. If everything went as planned, you should have moved a copy of second base.
  8. Now you can set self-cioy mode back to "Self", M-Tool:12a,1 and move and rotate your new third base to its proper position at the north-east corner of your baselines.

Snappinng and Moving 3D objects Snapping and moving 3d objects is a complicated thing. How can you control, or even tell, when working in Plan view what part of an object you are snapping to? This takes a little practice! The keys to controlling the behavior of snapping in 3d space is to adjust the snapping options, available by double-clicking your snap tool. To get a feel for this, do the following:

Understanding 3d snaps

  1. Set your view to Top.
  2. Zoom in on one of your bases so that you can easliy mouse over the corners.
  3. Set your Object Snapping mode to points, switch on grid snap.
  4. Double-click your Object Snap button to bring up the options.
  5. Set the Depth-Snap to "Use Closestt." Make sure all of the other options for Projeted and 3d Views are unchecked.
  6. Choose the Pick tool.
  7. Make sure that your Coordinates Palette is visible.
  8. Watch the z coordinate as you move over the corners of your base to the corner of a grid square. The Coordinates palette should reveal that the cursor snaps to the nearest (5" tall) point on the base.
  9. Now set the Depth snap option to "Farthest." This is the option you would use to make sure that the bottom of the base snaps to the correct z dimension relative to your reference plane.

YOu will find some other good exercises for precision drafting in 3D in the formZ tutorial page 63.

More Data Organization: Layers and Colors

Have I mentioned that scholarship and other cooperative information management efforts require more organization than mere self-centered doodling? If you ever want to share your drawings, or even use them again yourself at a leter time, you should give everything a logical organization. We have already seen how the objects palette can help us with this. Now, we will look at another very important CAD concept, Layers.

Layer management is discussed with examples in the FormZ tutorial at Page 214 and 219. What isn't described very well here is the process of moving things from one layer to another. For this, you should look in the FormZ Interfaces manual.

We will begin our layer structure by creating a new layer for our bases, then we will set the layer options so that we can paste onto this layer, then we will cut and paset the bases onto their new layer. Then, just for fun, we will play with colors and materials.

  1. Create a new layer in your layers palette called 'Bases".
  2. Bring up the Layer Options Dialog from Options->Layer...
  3. Check the box next to "Paste on Active Layer." (Why this isn't the default, I don't know!)
  4. Pick your base objects, either graphically or through the objects palette
  5. Cut them from Layer1 with Edit->Cut
  6. Make your bases layer active by clicking a check in the left-hand column of the layers palette
  7. Use Edit->Paste to paste the bases to the active layer.
  8. Check to make sure that the bases are there by turning off visibility on layer 1 and then bases to see if the bases show up and disappear appropriately.

Coloring: We will get much deeper into the subject of materials as this course goes on. For now, we will use rudimentary coloring just so we don't have to live with the random colors that formZ assigns to our objects. There are many ways to apply colors to single objects or to all of the objects on a layer. This topic is covered in depth in the FormZ tutorial on PAGES 214-219.

Coloring one object at a time

  1. Find the Surface Stylespalette or open it from the palettes menu.
  2. Pick a good style for a canvas base from the scrolling list of color icons. I like #10.
  3. Choose the color tool, M-Tool:14a,1 and look at the prompts palette. depending on whether you have a base picked already, the color tool may ask you to select an object, or to simply click to apply the chosen surface style to the currently picked objects.
  4. What happened? YOu won't see any color when your display is in wireframe mode.
  5. Use "Display->Interactive Shaded" to preview your new colors
  6. We will make the grass green later on in this exercise. Later we will map color images to surfaces for more realistic color.

FYI, you can also use the layer options to override the colors of all of the objects in a layer.

Creating the backstop and fences

The perimeter of the baseball field is established a fence around the outfield described as: provide a minimum distance of 325 feet from home base to the nearest fence, stand, or other obstruction on the right and left field foul lines, and a minimum distance of 400 feet to the center field fence. Behind Home plate there is a 20 foot tall wire back-stop that is 60 feet distant from the back of the plate. From this backstop, fences run paralell with the foul lines until they hit the outfield wall.

Modeling this perimeter and its fences in CAD will help us introduce a few more CAD basics:

  1. Precision drafting of irregularly shaped planar faces with combinations of curves and sraight sections.
  2. Directional snaps
  3. Polar coordinates
  4. Closing and coloring an open wire.

First the outfield fence. From Home plate, it should be 400 feet to the center field fence, but 325 feet along the foul lines. This can be accomplished with an arc (it won't be centered on the plate) but first, we need to mark off the right distances. For this we will use the segment tool, M-Tool:3b,2 with the 2D Surface Modifier, M-tool:2a,1. Extending the foul-lines exactly 325 feet along the x anf y axes will give us a chance to practice what we have already learned about precision drafting at the beginning of this lab. Then we will learn a new technique, using Polar Coordinates.

It will be helpful to keep this diagram on your screen for references to the anatomy of a baseball field.

  1. It is important to do editing in Wireframe view. The shaded views are useful for chacking things, but since they hide various things, it can be confusing to draw in any view than wireframe. Check right now to make sure that you aren't set to 'Interactive Shaded'
  2. Make sure that your Object type modifier is set to 2D Surface, M-Tool:2a,1. It is very easy to forget this. If you do, many operations you try to do later won't work and it is very confusing.
  3. Make Layer1 the active layer
  4. Use typed-in commands to make segments from 0,0,0, to 0,325,0 and from 0,0,0 to 325,0,0. You can use absolute cartesian coordinates for this. (Exgtending from 0,0 to A and C on the diagram)
  5. To locate the extent of the center-field fence, we will enter our first point in absolute XYZ coordinates and then uncheck the box next to the C in the prompts palette to switch from cartesian to polar coodinates, then make a line starting at 0,0,0 and extending 400' at an angle of 45 degrees. (to diagram Point B)

WE are now set up to establish an arc connecting the three points that we know are on our outfield fence. (Diagram points A,B,C) Check out the Arc tools under the Spline flyout at M-Tool:3b. The one that creates an arc connecting 3 points in clockwize fashion, is M-Tool:3b,13.

  1. You may want to set your view to 'Top' for this.
  2. Turn on endpoint snaps, and turn off grid snaps.
  3. Grab M-Tool:3b,13, and make an arc from the end of the left-field foul line to the top of center-field, and connect it to the right-field foul-line.
  4. Double-click to finish the arc.

Properties of curves in FormZ Your new curve is a parametric object. Although it is obviously displayed as a setries of straight chords, it is defined in your data base as a center, a radius and a sweep angle. Query the attributes of your arc, then press edit. You can alter any of these things. We will need to extend this arc in a few minutes as soon as we figure out where our side fences are. Before you get into heavy modeling in FormZ you will want to read up about smooth versus faceted curves and Display Resolution in the on Page 35 of the FormZ tutorial. If you don't like the rough faceted look of your arc, you can edit its Display Resolution to increase the number of facets used to display it.

The Backstop and the side fences: The backstop and the side fences sit 60 feet back of the plate and first and third bases, and then join up with an extension of the outfield fence. We can make the quarter-circle arc around the back of home plate (see diagram point E) by turning on grid snaps and using one of our handy arc tools. Then we can extent lines from the ends of this arc, paralell with the x and y axes, by turning on ortho snaps and dragging out the lines. We don't know exactly where these lines end just now, but we know that if they are as long as the foul lines, that this will be long enough.

  1. Turn on gridsnap and make a quarter circle centered on Home plate, with ends at (0,-60) and (-60,0).
  2. With end snaps and ortho snaps, W-Tool:5,2, turned on, drag out your side fences to approximately the same length as your foul-lines. (to Diagram points F and G.)

Extending arcs: the beautiy of precision drafting in CAD is that the precise locations of things, such as the end of our side fences, is determined by the intersection with our outfield fence. We don't know where this intersection is, until we extend both of these. In the next few steps, we will extend the arc of our outfield, to intersect with the side fences. We will then use the Break Line Tool to trim the ends of the lines and the Close Line tool to create a closed face from our several, as yet, unconnected segments and arcs.

Extending a curve

  1. Query the attributes of the arc that represents your outfield fence and push the edit button
  2. In the Arc Angle section back the start of the arc from 0 to 30 degrees and push the End of the arc to 180. Exit both the edit and query windows. The outfield and side frences should now intersect.

Trimming Lines and Closing the Perimeter

  1. Select the Trim Tool, M-Tool:11a,3. Look at its tool options. make sure that they are set to 'Trim Pairs of Segments."
  2. Click on one of your side fences (it is critical to pick on the side of the segment that you want to keep.
  3. Then click on the arc of your outfield fence (on the piece that you want to keep. You should see the dangling ends of these fences have been trimmed off.
  4. Trim the other corner.
  5. Move the pointer to the intersecton of the fences and click
  6. Now with the pick tool, and the topological modifier set to segment, you should be able to pick the dangling ends of the fences and delete them with the backspace key.

Joining a chain of segments

If we want to be able to make our field green, we will need to take the perimeter that we made and turn it into a closed face.

  1. It is critical that the Topological Pick modifier be set to "Object" at this time. If not, the Join operation gets very confused, and so will you.
  2. Pre-Pick each of the segments of the perimeter. Go around the shape in clockwise fashion.
  3. Now use the Join tool, M-Tool:11a,5 to join all of the segments. Pick the join tool and adjust its tool options to "Close Line Sequense."
  4. In order to see whether your join was successful in making a closed face, turn on a shaded view. Your baseball field should now be filled with color. Why not make it Green?

Some more notes about layers and saving

After all of that work, we want to save this perimeter on a different layer so that we can lock it and keep it safe. We should also save our formZ project. Notice that as we make objects that are part of our final representation, we are copying them onto separate layers. Things that have been intermediate to the model, such as ghosted operands, we are leaving in Layer_1. This is a decent way of working. Its OK to clean up Layer1 every now and then.

In terms of saving, you never want to 'Save' your projects. You should always "Save-As..." so that you will have a trail of intermediate versions you can go back to in case at some point you notice that something important has dissapeared. Also! Never edit projects that are on Floppies, ZipDisks, CDRWs or on network drives. Working this way will cost you your edits, and the files you are making them to!

Make a new layer for your perimeter

  1. Make a new layer named perimeter, and make it active.
  2. Use the picked tool, at the object level to pick your perimeter face.
  3. Copy and paste the perimeter onto the proper layer.
  4. Check to see if the paste went to the intended layer. Don't forget that you have to adjust the Layer Options to specify Paste to Active Layer.
  5. Lock the perimeter layer.
  6. Save your project as Baseball2.fmz

Raising the Fences

To finish our model of a prototype baseball field, we will raise the backstop and other fences. This will involve making a copy of our perimeter to a new lasyer, named 'fences,' then deriving extruded enclosures from them at various heights. Then we can play with simulating various materials on them.

Modelig the fences in 3d will give us an idea of how the baseball field interupts the circulation around it. A sports park may be more versatile if the field has no fence around it. Nevertheless, a representation of the fence will give an idea of how much space a Baseball Game requires.

Extruding the fences

  1. Make a new layer named Fences and copy your perimeter to it.
  2. To avoid confusion, lock and turn off all of the other layers.
  3. Set your topological pick level to segment, and pick the round arc of your outfield fence.
  4. Pick the Derive 3d Enclosure M-Tool:5a,6 and look at the tool options.
  5. Set the wall thinkness to 2 inches (the witdth of the frame of a chain-link fence or a wooden wall.
  6. Pre-Pick the arc of the oputfield fence and the two segments defining the sides of the field.
  7. Look at the prompts palette, it should say 'Click to create enclosure from picked.
  8. Click.
  9. Notice that the original segments of your perimeter are now ghosted. You can unghost them layer with the unghost tool, or you can chage the Status options of the Derive 3d Enclosure tool to leave the operand unghosted.
  10. Try a front view to make sure that your fence is actually 3d and that it is actually on the ground. (Always looking at your work from a single point of view can lead to some ridiculous errors!)
  11. Now set your display to Interactive Shaded, and rock the display around to look at your wall.
  12. Play around with applying different colors to your wall. Later on, you may want to experiment with applying textures patterns and transparency (which will show up only in RenderZone View.)
  13. Now, unghost the small arc that defines the backstop, and make it a fence, 20 feet tall.

Putting it all in a Neat Package

Now that we have created a model of the canonical dimensions of a baseball field, we should package it up so that it can be easily imported and used repeatedly in drawings. If we utilize the CAD concept of compound objects (refered to in AutoCAD as Blocks) and instances, we will be able to refer to this canonical baseball field in many drawings, and if we ever decide to change our prototype, changing the library version can cascade changes to each instance that refers to our prototype.

In FormZ, the notion of a shafred compound object is called Symbol this is discussed in the tutorial on pages 188-190.

To turn our baseball field into a symbol, we start by creating a new symbol library file. Then we select the components that we would like to package, and use the Symbol Create tool to create a symbol. It is important to save a version of your model before doing this, because making a symbol seems to rearrange your existing data in confusing ways.

Creating a symbol

  1. Save the current state of your project
  2. Bring up the Symbols Palette from the Pallettes menu.
  3. Click on the word 'Library' in the empty symbols palette to bring up the interface for managing libraries
  4. Create a new library file to hold your simbols. SInce we may be sharing these, you may want to include your username inthe name of the file, like pbcote_sportsfields.zlb Of course, you will want to save this somewhere where you will be able to find it later, such as the formZ directory with your other work that you keep backed up.
  5. Then unlock and make visible all of the layers that you want included with your prototype (probably not Layer 1.)
  6. Select everything by zooming out and dragging a box with your pick tool (Object Mode) around your entire model.
  7. Finally use the Create Symbol Tool, M-tool:10b,1 to create your symbol.
  8. I suggest that you pick the point (-60,-60) for your origin.

Out of the Ballpark!

Now that we have packaged our precisely-scaled 3-D baseball diamond we can exploit it by building baseball diamond scenarios on our site. Incidentally, it is just as easy for our colleagues to exploit our prototype in their scenarios. We may be able to trade a good baseball diamond for a basketball cage and a tennis court! The next thing we need to do is figure out exactly where our site is so we can begin building our metropolitan outdoor sports complex!

If we could get a scaled picture of our site into CAD, we would be a long way on our way. Lets take a look at the Rhode Island Orthophoto and DRG Browser, a terrific source of detailed, orthorectified, georeferenced aerial photographs.

After clicking and zooming and adjusting the frame, I arrive at the view that is referenced in the link, above. It has some meaningful bits of annotation that are worth noting:

The viewport above measures width=4000 and height=4000 feet on the ground. 
Each pixel you see measures 10x10 meters. The viewport is centered on X=359180, Y=256890 
(Rhode Island State Plane Feet, NAD83). 
From the download page, we selected the geotif image from the row that has the side-heading:
3x3ft pixels (1333x1333)
. The fantastic thing about this ortho-browser site is that it gives us, Not Only high resolution imagery of what existed on the ground in 1996, but also a precise spatial referencing system. What we know of the coordinate ststem of this image will permit us to very precisely standardize our scale and coordinate referencing system with our collaborators, clients, and anyone else who adopts this state-standard coordinate system.
Rhode Island State Plane Coordinate System, North American 
    Datun 1983 U.S. Statute Feet.
How noble is it that the folks from MIT should make a tool that makes such information easy to get, and the at the University of Rhode Island for populating this system with a state-wide spatial referencing system? This is truly worthy Landscape and Urban Design scholarship!

To make a long story short, there IS a way to get this information into CAD, and we will tell you how to do it in the next lab. But just to make things interesting, we are providing you with a ready-made form-Z site map that has our image as a backdrop that we can use in wire-frame mode. The image is also mapped to a surface that renders well in Interactive Shading or a RenderZone display. This shortcut will provide a fertile ground for exploring the possibilities of CAD for playing with spatial ideas.

Download and Open the Fields-Point Site Project

This ready-made project includes our orthophoto: site_ortho3x3.tif and a formZ project: fp_ortho_base.fmz that references it as an Underlay, for drafting in Wireframe mode, and as a texture-map referenced to a face, which looks nice in Interactive shading mode and RendeZone view. THe image must be in the same dirctory as the FormZ ptoject.

  1. Right-Click here to download a zip archive of the ortho_base project.
  2. Extract the contents of the zip file to your working folder
  3. Open the fp_ortho_base.fmz project in FormZ.
  4. You should have the orthophoto in your window, referenced in the Rhode Island state plane coordinate system (units: feet.)

Placing and Adjusting Basball Fielfd Prototypes

This has been a long lab, but we are almost done! All we have to do now is learn to open our symbol library, and to place symbols. This is covererd in the tutorial on pages 188 190.

  1. Open your Symbols Palette, and load your Symbol library that you created a few steps ago.
  2. Highlight your baseball field symbol in the symbol palette.
  3. Use the Symbol Place tool M-Tool:10b,2, to place an instance
  4. Now you can use your copy, move and rotate tools to arrange baseball fields wherever you want to.
  5. If you ever have an improved baseball field prototype, you need only to replace your old symbol in the library to update all of your instances!