Loading

Site Modeling in Context

Obtaining And Transfroming Elevation Data

Place-Based design projects benefit from an understanding and representation of the local terrain. Terrain data is surprisingly easy to obtain and convert into useful representations that may be used in GIS and also popular CAD and 3d modeling formats. This page discusses the how to obtain georeferenced terrain data for nearly anywhere in the world and georeferencd aerial photography within the United States. A few tools are presented for transforming these raster terrain models into: synthetic shaded relief images; contours for laser cutting; surfaces for 3d visualization, and editable breaklines that serve as the basis of earthwork and grading studies.

Some things you can do with digital elevation models

Digital Elevation Models (DEMs) are a type of raster GIS layer. Raster GIS represents the world as a regular arrangement of locations. In a DEM, each cell has a value corresponding to its elevation. The fact that locations are arranged regularly permits the raster GIS to infer many interesting associations among locations: Which cells are upstream from other cells? Which locations are visible from a given point? Where are the steep slopes? One of the most powerful applications of DEMs is adding synthetic hillshading to maps so that the map reader may see the relationship between terrain and other things you may be mapping.

A Digital Elevation Model (DEM) is a raster of elevation values. Rasters represent the world as regular arrangements of pixels (cells). Rasters lend themselves to systematic analysis of the relationships among places and their properties.

For example, a Raster GIS can calculate many useful derivitives of elevation, such as: Slope or Aspect -- the direction of slopes or Visibility -- what is visible from a spot?

Synthetic Hillshade calculated from a DEM is a great way to create visualizations of terrain with other semi-transparent themes. DEMs can also be used to create 3-D scenes or to create contour which may be exported to CAD programs.

Download the Sample Dataset

To save time in this tutorial, and to eliminate crazy variables that may cascade from oddities of your particular download, the rest of this tutorial will use the following sample dataset:

Deeper Reading

... from the GSD GIS Manual


Finding Free DEM and Land Use Data on the Web

National Elevation Dataset and NLCD, National Land Cover Characterization Dataset are a complete seamless coverage of DEM and Land Cover. These are available for free download via National Map Viewer This is a new means of getting USGS data, and it seems to be even more confusing than the old one!!!. There is a decent step-by-step explanation on this page.. Or, Take a look at this annotated screenshot.

Hint: The 1/3 ArcSecond Elevation data are not available for all areas. For this tutorial, I recommend that you download the 1/3 Arc Second NED Data -- or use the tutorial dataset, linked above.

For international data, the NASA Shuttle Radar Topography Mission has produced a nearly workld-wide elevation model that you can download in tiles from the CGIAR-I Google Earth - Based Browser for SRTM Data click the Google Earth link at the bottom to view and select tiles from the world wide elevatioopn dataset to download in geotiff format. These should work easily with the techniques discussed below.

If you are willing to go through a rather annoying registration process you may download a slightly higher quality elevation data for anywhere in the world from the Aster Global Digital Elevation Model. There are a few ways to get aster data at the USGS The USGS Distributed Active Archive Center. About the Aster Global DEM .

Each of the elevation models we have discussed are collected from the sky with technology that does not penetrate the water reliably. Therefore, in these terrain models, the surface of the water registers asd elevation. If your site is on the coast and you want to know the elevations of the underwater landscape, you may want to check out The NOAA Estuarine Bathymetry download site.

A world-wide bathymetry dataset has been compiled by The General Bathymetric Chart of the Oceans (GEBCO) Their data is aviable for download from British Oceanographic Data Centre. Though this process is a bit convoluted and poorly documented. Users on the GSD network are encouraged to use our local copy of the GEBCO Bathymetry dataset with the GridView extraction sodtware located in goliath://geo/gebco_worldwide_bathymetry.

Our tutorial dataset includes a USGS_Downloads folder that contains an aerial photo and an elevation model as downloaded from the USGS Natioanl Map Viewer. If your images come back as multiple files that have large balack areas, you can mosaic these together using the Mosaic Tool which can be found in the Geoprocessing Toolbox under Data Management>Raster>Raster Datsset tool set.


Special Notes for Handling Elevation Rasters in ArcMap

  • If get an error message from ArcMap telleing you that This Tool is not Licensed you should go to Tools->Extensions and check the boxes next to 3d Analyst and Spatial Analyst
  • Alsways save your output rasters as Imagine Image format files. This format is the most trouble-free of all raster formats supported by ArcMap. To do this, save the image in a plain folder (not a geodatabase) and give the file a simple name (no spaces) and add a .img suffix to the file name.

Mosaicing Rasters

It is often the case that you are forced to download raster data in multiple tiles. This can present a problem beccause some operations are much more straightforward when working with a continuos surface. And so you first processing step may be to create a mosaic of all of the rasters. To do this you would use the Mosaic To New Raster tool from the gepoprocessing toolbox under Data Management > Raster > Raster Dataset > Mosaic to New Raster For most purposes the choice for pixel type would be 16-Bit Signed which can handle negative numbers with decimal places. As always make sure your output raster has a .img suffix. If you are mosaicing your rasters it is best to do this before you reproject it.

Reference:

Choose an Appropriate Coordinate System

IN the next several steps we will explore the the data we have downloaded in Windows Explorer and in ArcMap. The coordinate system used for the elevation rasters used Decimal Degrees of latitude and longitude for X and Y and meters for the elevations (Z). Most of the things we want to do with elevation -- such as creating a hillshade raster or exporting contours to CAD require us to transform this coordinate system so that X, Y and Z are in the same units. More details about geographic coordinate systems are discussed on the page, Principles of Geospatial Referencing Systems. To make a long story short, we need to choose an apropriate projected coordinate system for the location we are studying. The simplest guideline to follow in choosing a local coordinate system is to use the appropriate zone of the Universal Transverse Mercator Coordinate System. The tutorial dataset includes a utm.shp layer that will help you determine which UTM zone your location falls inside. This same UTM shape file can be found in your c:\program files\arcgis\reference systems folder.

References:

Choose a Local Coordinate System

  • Turn on your UTM layer
  • Zoom out until you can see the red lines that define the UTM zones.
  • Click on your zone with the Info tool to reveal its number. Our tutorial dataset falls in UTM Zone 19.
  • Lets set our data frame projection to project our data apropriately, by double-clicking on the heading that says Layers at the top of your ArcMap table of contents.
  • Now lets set the geoprocessing environment so that all of the outputs of our operations will come out in UTM meters.
  • Do this set this in Tools > Options > Geoprocessing Options > Environments > General Settings
  • Set the coordinate system to the aporpriate UTM Coordinate system. If your study area is in the United States, consider choosing a coordinate system using NAD83 (the north american datum of 1983. If your study area is outside the US an easy choice is WGS84 (world Geodetic Spheroid of 1984.

Reproject and Reformat your Elevation Model

By default the elevation rasters that the USGS gives you are formatted as ArcInfo Grid datasets, which are not files, but inter-related directories (or folders) information which have to be handled carefully, lest they become corrupted. So while we are reprojecting our elevation model, we will also transform its format to the nice, simple Imagine Image format. The next step will transform the coordinate system of your DEM.

About Resampling: When a raster dataset is projected from a plain geographic coordinate system to a projected one, the size and shape iof the cells is transformed. You can think of Resampling as creating a new grid of cells and assigning values to the new cells based on the values of the old cells. The default method (Nearest Neighbor Resampling) simply assigns a value to the new cell based on the value of the cell in the old raster that is nearest to the center of the new one. This is the right thing to do with rasters whose values represent categories. For rasters that represent a continuous surface the Nearest Neighbor method can create stair-stepped stryations. For continuous value rasters, like elevation models, the Cubic resampling method is best.

References:

Reproject your Elevation Model

  • Click the little red toolbox icon on the ArcMap toolbar to bring up the Geoprocessing Toolbox.
  • Open the following chain of expandable toolsets: Data Management Tools > Projections and Transformations > Raster . Project Raster.
  • Use the Pulldown Menu for Input Raster to choose your elevation model.
  • IN the Output Raster Dataset blank, choose a name and filesystem location for your new raster. Note that the default option will almost always be wrong. Put your output raster in a folder within your GIS project folder. If you are just playing around, I recommend that you put the result into a foldrr named scratch. For the name of the raster be sure to give the file name a .img suffix. >img wil lmake an Imagine Image format, which is trhe most robs, problem free raster format.
  • In the pull-down for Output Coordinate System choose As Specified Below. Then click the browse button just below the Output Coordinate Slot, and in the next box choose Select.
  • If you know what projected coordinate system you want to use, you should now browse for it.
  • If you have chosen a UTM projection Case from this map of utm zones, you would navigate the projection broser as follows: Projected Coordinate Systems > UTM > WGS84 and then choose your hemisphere and zone.
  • Finally, go the the blank labeled Resampling Technique and choose Cubic.
  • Click OK until your DEM is projected!

Transforming Rasters with Geoprocessing Tools

Digital terrain models are interesting to look at, but more importantly, they can be transformed into other forms of data that are useful for many things. We can calculate slope and aspect, we can make shaded relief that makes the terrain model much more informative graphically. We can even create contours at whatever contour interval we want. Contours are also useful graphically, for laser cutting and exchange of three dimensional models with other programs. Probably the most efficient ways to terrain information out of GIS and into a 3d modeling package is as a trangulated surface. This is also quite easy to do!

We will begin by transforming our elevation raster to a shaded relief map and an aspect layer using wizards form the ArcGIS Geoprocessing Toolbox. You will see how to use the individual wizards in the toolbox. A the end of this document, you will see how geoprocessing tools can be chained together to create custom tools that will let us create custom wizards to automate useful tasks!


Transforming Elevation to Hillshade and Aspect

These two tasks will allow us to introduce the toolbox and a few simple wizards. The input raster for each of these procedures should be projected as described above.

References

Create Hillshade and Aspect Rasters

  1. Make sure you have the Spatial Analyst and 3d Analyst extensions enabled in Tools->Extensions
  2. Open the Toolbox Panel in ArcMap by clicking the little red toolbox icon raster.
  3. Use the Search Tab at the bottom of the tool boc to find the Hillshade Tool.
  4. Create a hillshade raster.
  5. Take a look at the Display properties of the raster. Try adjusting the transparency of the hillshade to 60 percent and displaying it over your photograph.
  6. note that if your hillshade raster appears to be very high contrast, it is because you are using the unprojected raster that uses decimal degrees for X and Y and meters for Z. Click Here to see an example.

Making Maps with Terrain Shading

The trick of synthetic relief shading demonstrates a fascinating phenomena of visual communication. Even though the default sun azimuth for the hillshade tool (315 degrees, northwest) may never actually occur at your site, you should use this (or some other northern angle.) Setting your synthetic illumination to be in the north is an important convention because shading works because your eye can easily imagine bumps sticking out of the maps, are being highligeted by the source of light in the room (which is normally overhead.) If the illumination is coming from below, the eye and brain still assume that things are highlighed from below, so the map will appear inside-out.

Check out these examples: Mouse over the words in the left column to change the image

Conventional Illumination This sun angle, 315 degrees, never occurs in Oregon, but the hillshading makes the mountains appear to pop out appropriately. Note that the stream is running through the valley to the river.

Natural Illumination This sun angle, 135 degrees, (Southeast) may simulate a mid-morning condition for the site, but the trick of synthetic hillshading makes the valleys, not the mountains appear to pop out! Hillshading is an optical illusion that takes advantage of our assumption that the illumination is from overhead and shadows occur underneath things, not on top of them.

Natural Sun Angle, map oriented north-down With this map we can have a natural sun angle -- and effective relief shading -- at the expense of the cartographic convention for keeping north at the top of the map.


Making Contours

The next set of steps covers the creation of contours. The "Create Contours" tool in the surface toolbox makes it straightforward to choose a contour interval and to scale the vertical units using a Z-Factor. These contours can also be exported to CAD. The references and processing steps listed below cover the basic tools for creating contours. For a more nuanced approach, take a look at the DEM to DXF Contours tool described in the next section.

References

Create Contours

  1. Open the 3d Analyst->Raster Surface->Contours tool.
  2. Open the help panel on the wizard, and mouse over the different fields.
  3. Click the Help link at the top to look at the entire help document.
  4. Take a look at the environment general settings of the contour tool. Keep in mind that the Output Coordinate System determines what your X and Y units are going to be.
  5. If you want to change the Z units to feet, use a Z-Factor of 3.28.
  6. Take a look at your new contour layer.
  7. To convert your contours to CAD, use the Conversion Tools -> To CAD toolbox to generate a cad file form your contours.
  8. To generate CAD contours with elevations, see Converting GIS Data to CAD

Exchanging an Elevation Model with Rhino via an ASCII Point Cloud

This technique is particularly useful for importing terrain models to Rhino via the RhinoTerrain Plugin. Many people try to do this via contours, which seems logical, except that much information is lost in the transformation of raster to contours. Converting to a pointcloud exchanges the elevation data dcell-by cell with virtually no loss. This can then be converted to a mesh in rhino and then you can cut contours as needed from this mesh, as described in the Rhinoterrain Tutorial. The Rhinoterrain workflow also benefits from the capability to incorporate a georeferenced image for reference and for rendering, draped on the terrain surface. Making all of this work is accomplished by creating a reference frame, as described in the tutorial Creating a Georeferencing Frame.. If you aren;t interested in exchanging images whith rhinoterrain, you can ignore step 3 in the instructions below.

  1. Project your raster using the cubic resampling method as described above.
  2. Zoom in to the area you want to export
  3. Enable the Spatial Analyst Extension by going to Costomize>Extensions and checking the apropriate box.
  4. Open the Toolbox by clicking the little red toolbox icon on the arcmap toolbar.
  5. Find the Conversion Tools > Raster >Raster to Ascii tool
  6. Click the environments button. Click Analysis Extent and either choose Same As Display or choose the layer that contains the registration frame that you made.
  7. Export your raster to ascii.
  8. Import your pointcloud and your frame shape file to rhino using the RhinoTerrain plugin!!


Using Models to Chain Together Series of Geoprocessing Steps

The following parts of this tutorial demonstrate how chains of geoproceesing steps can be put together in models, which are essentially custom tools. In addition to providing a means of pulling several wizards into a single tool. These models allow you to chain the output of one wizard into the next, and also let you fill in the blanks in some of the wizards, and expose other wizard options and environments to the user through a simple interface.

We aren't going to go into all of the techniques of building models here. One of the neat things about models, is if they are designed well, the user doesn't necessarily need to know what is going on inside. Another really good thing about them is that they allow an expert to very succinctly document a procedure so that users can see exactly what is going on if they are interested. There are some very useful models included with this tutorial, that do things like creating generalized contours and clipped out Triangulated Mesh Models this will be a good occasion to take a look at them and see how they work. We will get to that, but first lets create a simple model to create contours to introduce the basic contents of a model.

References

Geoprocessing Tip Sheet

  1. Create a model that smooths your raster using focal statistics before you make contours
  2. Add a function to your model that eliminates needless vertices by adding a Simplify Line tool to your model.

A One-Step Process for Converting Raster Terrain Models to CAD

Most GSD students think that they have to do everything in CAD -- even though CAD applications are really bad at dealing with very large models and real coordinate systems... Anyway, if you really want to have a terrain model in a CAD package, GIS can help. As you will see from the references above, converting 3d contours to AutoDesk formats involves a couple of steps. Luckily thanks to Geoprocessing models, I have been able to wrap all of the smoothing, a raster turniong it into contours and simplifying them and finally turning it into a DXF file -- all in one step!

References

Turn Raster Terrain Models to Contours with any given contour interval

And Excess Vertices that make your CAD meshes needlessly complex can be Removed!

and the resulting contours are converted to DXF!

YOu may also be interested in the superior meshes that are created directly from raster terrain models These can be made with a tolerance that lets you get the essential information from the terrain model without any excess polygons.

these meshes can be exported to Sketchup and in turn exported to dxf of 3ds formats.

Note! if you try to use a function, as is suggested below, and get an error to the effect This Tool is not Licensed you should go to Tools->Extensions and check the boxes next to 3d ANalyst and Spatial Anayst

Using the GSD Terrain Tools

  1. Make sure your data frame coordinate system properties to a projected coordinate system as described above. These tools will crash if you fail to project your dataframe accordingly.
  2. Look for the GSD Terrain Tools toolbox Then simply double click on the tool you want to use. If you don't know what values to fill into the blanks, simply click on the blanks and look for the tool-tips in the help panel on the right.
  3. If the modeel seems to be giving you error messages that don;t make any sense, try right-clicking on the model and choosing edit here you can check out, and set the parameters in the blue ovals and then choose Model->Run Entire Model.
  4. If after trying the previous step, if the model is still refusing to run -- make sure your dataframe is projected appropriately, save-as your arcmap document with a new name, quit arcmap and start it again.
  5. You may want to try this tool several times with different settings to get the reults you want.

Converting to TIN and Exporting to Sketchup

To export your mesh to sketchup, install the sketchup arcgis plugin into ArcMap. If you are on a computer in room 516, this can be accomplished by choosing Tools->Customize and simply check the box for Sketchup 6 Tools. If you need to install the sketchup5 plugin for ArcGIS on your computer, go to the the winapps/sketchup directory, and follow the instructions.

TO export your TIN to sketchup, simply push the sketchup button, and go to the TIN tab, and uncheck the box that says 'Exclude form Export.'


Visualizing your Terrain Data in 3d

Apologies for this cursory teeaser here, but it will have to do for now. It is surprisingly easy to create visualizations of your terrain data in 3d uusing ArcGlobe. YOu will find useful information about this in the Using ArcGIS 3d Analyst User Guide..

If you open the dem_demo_pt2.mxd in the gis/pbcote/docs folder of your sample dataset, yoiu will see a nice project that makes a nice image overlay using the raster elevation model and contours portrayed in nice colors to indicate land and water, and overlayed transparently on top of the areial photograph. This image was exported as a jpg withg a world file from ArcMap using File->ExportMap. This jpeg will be georeferenced with a world file, and will inherit the projection of the data frame from which it was exported. You wil lhave to use arcCatlog to uypdate the spatial refernce properties of this image before it will open in arcglobe. All of this is worth it, as you will see, if you open the fp_3d.3dd file in gis/pbcote/docs. Consult the 3d Analyst use guide to see how this file can be used to visualize your terrain and buildings in 3d! Hint: movew the DEM layer to the elvation layers group!