Loading

Graphic Design Workflows

Exporting From ArcGIS to Illustrator

The workflow of preparing maps and diagrams for presentations often involves a hand-off at some point between ArcMap and a vector drawing program such as Adobe Illustrator. This can be useful if you wish to use geometry from GIS as the basis for diagrams that you would create in illustrator, or if you want to use illustrator to fix some of the awkward legends or labels that ArcMap makes for you.

The short story here is that it IS possible to export an ArcMap map composition to an Adobe Illustrator file in such a way that the layers are intact with all of their crisp vector integrity. But there are a number of tricks that you must know on both sides of the ArcMap>Illustrator Exchange.

References

The goal is to set up a document that transfers all of your vector layers to illustrator as vectors and your raster layers as rasters. There are a number of 'features' of the illustrator exporter that make this tricky:

The sign that you have violated any of these conditions will be that ArcMap will rasterize any of your layers that occurs underneath the first layer that violates any of the above rules. Knowing this can be useful for troubleshooting the exchange.

Setting up your ArcMap Document

You may have designed a map in ArcMap with a nice graphical hierarchy that uses transparency and group layers. Don;t worry, whatever transparency effects you had applied to your ArcMap layers, van be re-applied in Illustrator. What we are going to do now is save the map document as "Illustrator_Exporter.mxd" or some name like that -- so you aren't;t writing over your nice ArcMap composition. Then we will alter our special map as follows:

  1. Open up all of your grouped layers in the ArcMap table of contents.
  2. Turn off any layers that you don;t want exported to illustrator
  3. For each layer that you want exported to Illustrator, if the layer is part of a group drag the layer out of its group. Leave the stack order the same. Thus you will end up with a bunch of singular layers near the top of the table of contents.
  4. If there are raster layers, or layers that can;t be removed from their groups, (such as the image layers from ArcMap On-line) leave them at the bottom of the order.
  5. Check the Display properties of each layer and make sure none are transparent.

Now you should be ready to export to illustrator!

Exporting to Illustrator

Exporting to Illustrator uses the File->Export Map function. It works both in Layout View and Map View. One advantage of doing this in Layout View is that you can set up a page size and add a scale bar in layout view, and this make it easier to predict things like how your line weights are going to look. There are a few settings to look after when you are in the midst of this export process.

  1. Choose File->Export Map.
  2. Use the Save as Type pull-down to choose AI (adobe Illustrator.)
  3. Click the Options button on the lower left corner of the export dialog to reveal the export options.
  4. Under the General Options tab, the setting for DPI reflect the resolution of whatever information is going to pass to Illustrator as Pixels. If you intend your map to appear in illustrations at the same dimensions as your ArcMap Layout, then you can get away with, say 150 - 200 DPI. If you intent for people to zoom in on your illustration then you may want to set it higher. Of course you will check the detail in illustrator to make sure that you have not lost anything.
  5. Under the Format Options tab, you will want to set the Picture Symbol pull-down to Vectorize Bitmap or Picture Symbol Fills
  6. Check the box to Covert Marker Symbols to Polygons
  7. Click Save to begin your illustrator export!

Things to Do on the Illustrator Side

After a few seconds, you should have an Illustrator Document that you can open in Illustrator. Here are some of the steps for checking out your new illustrator file and starting to use it.

  1. Open your new Illustrator document
  2. Illustrator will complain that the document includes fonts that were created in a previous version that need to be converted. Click Yes to convert.
  3. After the Illustrator document opens, look at the Layers Window to examine the layers. You should have one layer in illustrator for each of the vector layers in ArcMap. If you had any raster layers in your export, they should be wrapped up with the bottom layer named Image.
  4. If the condition described above is not the case, If not, you may skip to the trouble-shooting strategies discussed later in this web page.
  5. you now have the ability to adjust the transparency or the drawing order of any of your layers using the layers window.
  6. It may be your strategy not to use Illustrator to get deep into adjusting the symbology of objects with a particular layer. Such a strategy may use the ArcMap detail as a background for additional layers that are created in illustrator . The illustrator document can then be used to suppress or to show layers that you have brought in from ArcMap.

Editing detail in Illustrator

If you want to use illustrator to select and edit geometry that has come from ArcMap, you will find that many of the individual layers that have come from ArcMap are actually group layers that employ Clipping Masks. These can be released by selecting the geometry in question and choosing Object->Release Clipping Mask. Furthermore, some of the geometry with a layer may be grouped. And of course, these can be ungrouped by right-clicking on the layer and choosing Ungroup.

Strategy

So you see that this workflow from ArcMap to Adobe Illustrator is not a simple easy-in, easy-out situation. One of the messages from this, is that you want to plan carefully how much work in symbology and labeling that you want to do on the ArcMap side in order to avoid awkward situations in Illustrator. Another thing to look forward to is the likelihood that you will have to do more than one export to illustrator. Once you have exported a bunch of stuff from ArcMap and begun to create new layers, etc in Illustrator, you will find some new GIS data that you want to incorporate. For this is it very useful to have a fixed frame on your ArcMap side that you can include in each export to use as a guide for registering each new layer that you export. A simple way to achieve this is to set up your map with a layout window, and create a Bookmark in ArcMap to save the extent and scale of the map data within your layout. This way even if you accidentally zoom in or out or pan the map inside the window, you can always bring the map to the exact same position with the frame before you export it.

Troubleshooting

You should always expect problems, and so if you encountered any in this export to illustrator it will not be surprising. Most problems with illustrator exports manifest themselves by rasterizing layers and groups of layers that you had expected to be vectors. This usually results from violating one of the rules listed at the top of this document, and or failing to set one of the setting listed in the section about Exporting. IN any case, you sometimes can figure out which layer is the culprit because the first layer to be rasterized will be the one that has a problem.

It may be that you have done everything correctly and still some layer or other is being rasterized in thin strips. This may result from exceeding the limit on number of vertices that can be exported. If, for example, you are trying to export many thousands of polygons, it may be simply too much. The troubleshooting advice I can give you is to divide and conquer. Trrn off half of the layering in ArcMap and try the export again. If you still have a problem, then turn off the other half. This way to can quickly narrow down which layer is the problem. If there is nothing wrong with the settings for that layer or in your Export Options, then you may just have to live with this layer being rasterized.