Loading

3Dn Site Modeling in Context

Sketchup 101: Model Organization and Massing Studies

This first tutorial in site Modeling in Sketchup will introduce the ways that we can organize and experiment with complicated arrangements of geometry using Google Sketchup. We will develop a schema for representing sites involving terrain, buildings, vegetation and miscelaneous furniture. Our model organization will allow us easily create and compare multiple alternate scenarios for a particular site. Owing to the elegant way that sketchup integrates geographic referencing to our models, this demonstration will demonstrate the awesome architecture for web-based collaboration.

Download Model Resources

References

It would be difficult to improve on the video tutorials provided on the Google Sketchup Training Site.

Throughout this tutorial, specific terms are highligted in Bold. These may be looked up using the search tool in Sketchup's On-Line Help for more detailed explanation of the usage of the tool in question.


Fluency in Design Representation

Becoming fluent in any expressive medium can take a little practice . In the area of 3d modeling, the chief barriers to fluency boil down to these problems:

  1. Learing to orient the model and to place details things exactly where you want them.
  2. Learn to control the relationships of Simple Entities, Layers and Groups
  3. Develop habits of organizing information in our models so that we will our models will behave predictably and reliably even as they grow more expansive and more complicated.

Understand the Modeling Problem

We could begin by just playing around, but since time is limited, we will get straight to a real problem. We are interested in understanding how the dimensional requirements of City of Boston's zoning ordinance affect the development possibilities for a parcel located at 31 Tileston Street in the North End neighborhood. So we have downloaded a couple of pertinent documents from The Boston Redevelopemt Authority's Web Site and put them in a folder in our working directory.

The gist of the problem is that

Our challenge is to compare several massing alternatives for this site, and to evaluate their visual and micro-climate impacts on the park. Along the way, we will also learn a bunch of things about how to organize information in sketchup.

Acquire a Georeferenced Aerial Photo

One of the neatest things about sketchup is the way that it handles georeferencing. Using the File>Geo Location tool you can grab a piece Google's worldwide aerial photography to use as a basemap. This is useful enough, but what is even more amazing is that by beginning a model this way, your sketchup model is georeferenced. Objects that you create in such a model can be exchanged with other programs that understand georeferencing and will land in the right place. Imagine the possibilities: your model can be looked at in the context of models that other people have made for the places nearby! Imagine the consequences for studio!

References

  1. Choose File > Geo Location
  2. Type "31 Tileston St, Boston MA" into the search tool.
  3. click Grab Location and adjust the handles on the window so that you have the buildings on Tileston Street and the fountain in Paul Revere Park.
  4. Examine the various layers of the model. Orbit around and zoom and pan with your mouse. Look at the Google Earth terrain from the side to see that it is 3D.

So now you should have a handle on using the mouse and turning layers on and off. For now, you will want to leave the terrain layer off, as we will see, it is better to model things on a nice flat plane.

Create Groundplan Elements

We will begin our model by drawing the edge of the street in front of the site. By starting the model wityh a nice long straight line we will have a reference line from which we can make a parallel line for a sidewalk. Creating this will give us an opportunity to demonstrate how we can use zoom in and out while using the Draw tool and how to use the Tape Measure Tool to create helpful guides, or Construction Lines that may be parallel with other geometry in the model. This is particularly helpful when creating streets.

References

Create Groundplan Elements

  1. Use your scroll wheel to get over your airphoto so you can see the entire thing. Notice how you can see the curb on the north side of Tileston street. This is a good baseline. Generally when tracing things on aerial photos yu want to find something that is on the ground. Note how the fronts of the buildings are leaning back.
  2. We want to make a line that follows the curb around the block. so grab the draw tool and try to place it right at the corner of Tileston and the cross street. Its hard to control the location of the cursor when you are zoomed way out, so place the draw tool, without clicking) over the corner you want to draw on, and roll in with the scroll wheel to get close. Now you have more control.
  3. Now start your line.
  4. Now we are so close in that we can't see the other end of the block. So lets roll out with the scroll wheel. Once you roll out far enough you can place your draw tool at the other end of the street and roll back in. YOu might also want to turn teh view around by pressing the scroll wheel in and orbiting the whole view. This takes a little practice to get used to, but changing your view while drawing in sketchup is essential!
  5. So now you can finish your sidewalk line. The sidewalk is about 4 feet wide. So now you can use the tape measure tool to click the curb line with the tape measure and drag out a guide that will be parallel with the original line.
  6. While you are doing this, you can see that the distance of your parallel guide is showing in the Measurements Toolbar that is at the bottom right corner of the screen.
  7. Without clicking anything, just type "4'" and notice that the guide jumps to exactly to 4 feet in the direction that you dragged it!
  8. This guide will be helpful for drawing the other edge of the sidewalk and also the other edge of the street, all parallel!

Create a Parcel

The first step in understanding the massing opportunities on a parcel is to learn what the total land area is for our 19'x38' parcel. Creating a parcel using sketchup will give us the opportunity to learn how to use the basic drawing tools, including the Draw Tool, the Measurements Toolbar, Inferences and Inference Locking. The first thing we will do is practice making a parcel off of the aerial photo so that we can better see what we are doing. Once we have got the hang of using all of these tools, we will create a parcel where it belongs.

References

  1. Maximize your sketchup window so that you can see the Value Control Box at the bottom right corner.
  2. Grab the Draw Tool and begin a line. YOu can see how Sketchup helps you draw parallel to one of the axes by turning the line red or green or blue depending on which access you might be trying to parallel. For now, drag a line that is not parallel to any axis. Note the length of the line is being displayed in the VCB.
  3. Our parcel is exactly 38 feet long, so enter this on your keyboard. Do not click in the VCB, your keystrokes will go in there directly. Hit enter, and the line will extend in the direction we established with the draw tool, until it is exactly 38 feet long.
  4. Now we want to make the front of the parcel exactly 19 feet long. We will use a Perpendicular Inference to make sure that the line is perpendicular.
  5. Continue drawing from the last point, but try moving the mouse around until the line you are drawing turns pink. THis indicates that you are perpendicular to the first line. If the inference does not appear, go back with the draw tool and stroke back and forth over your first line to remind Sketchup that this is the base from which you desire to be perpendicular. Then try again.
  6. Once you have the line extending along the pink inference, type 19' and hit enter.
  7. To finish up, we want to drag another perpendicular line to the back of the parcel. IN this case we will start the line, and rather than entering the length in the VCB, we will hold down the Shift key, once we have found the pink inference. This locks in the direction we established, and we can then determine the length by clicking on the beginning point for the first line we drew. Notice that the VCB indicates that the new line is exactly 42'.
  8. Finally we can close the parcel with one more line.
  9. Right-clicking on a parcel will now let us examine the polygon's Entity Info including its area.
  10. Now that you have practiced making a parcel, lets create the parcel in the correct place on the aerial photo.
  11. Now create your 10 foot backyard setback. Hint: use the TapeMeasure tool to create a guide first.

Create a Building, Understand Groups

So now we have a parcel. Lets create a building. We will keep it simple at first and just use the line tool to create a new polygon on the parcel and then we will extrude it up with the Push-Pull tool. With this brief experiment, we will see that the way sketchup makes inferences about geometry, and lets us cut into faces and push and pull them in intuitive ways, requires that we learn to control how objects are grouped.

References

Create a Building

  • Now lets put a building on our parcel.
  • Use the Draw Tool to put a building footprint on your parcel.
  • Then use the Push-Pull Tool and the Measurement Toolbar to extrude the building to 40 feet.
  • Triple-click on the building to select all of its faces. Oops, now the parcel is considered to be attached to the building! Ick!
  • Tilt your drawing up and notice that your building has cut a hole in the parcel. This is not good!
  • Use Control Z to undo all of the steps that you just did to create the building.

What you have just observed is that if you are not careful, entities in your sketchup model will stick to eachother in awkward ways. This is why it is important for you to understand how to use groups and to be careful about grouping the entities you make, and how to control the group context of the things that you are creating as you go along. Now lets do it right.

Organizing the Model with Groups and layers

Lets take a look at how our parcel is represented in SketchUp. We can use the select tool to select and get info on each of the edges of the parcel, and also the face that is created inside. Faces and Edges are the most basic types of objects in SketchUp. The entity Info window tells us that these are all on Layer0. This is the way it should be. until you are very comfortable in SketchUp, All faces and edges that you draw should always be on layer 0. But since the edges and the faces make up a higher-order object -- a parcel -- it will be useful if we can group it and give it a name. Then we will make a new layer for Parcels and move our parcel into that layer. Groups help us to organize our model into hierarchies of objects -- so we don't have to worry about every single line and face. Layers allow us to organize the grouped geometry of the model into thematic categories that can be turned on and off. It is very important to learn how to use groups and layers. They will allow us to control what we are selecting and editing even after our model becomes very complicated.

References

Group the Parcel

  1. Double-Click on your parcel to select all of the edges and faces all at once.
  2. Right-Click on a part of the parcel and choose Make Group.
  3. Observe that the parcel now has a blue box around it. You can double-click the parcel and it appears enclosed in a gray envelope and you can select the primitive edges and face. This is known as being In the Context of the group.
  4. Click outside of the parcel to leave its context. You can't disturb the geometry of parcel's contents now unl;ess you deliberately enter the context of that group.
  5. Select the parcel group, right-click and choose Entity Info you can name this group: Parcel.
  6. Open the Layers Window and click the plus sign to create a new layer Called "Parcels".
  7. Use the Entity Info window to place your Parcel onto the Parcels Layer.
  8. Now double-click in Parcel, and note that the group highlights with a gray envelope. This indicates that you are Inside the context of the group now you could edit the parcel or select individual edges and faces inside the group.
  9. Check entity info on an edge or face within your parcel group. Note that the individual elements of the group are on layer zero. While the group itself is on the Parcels layer. This is as it should be. Layer 0 is the place where all primitive geometry should be.
  10. Click off the check box on the parcels layer and note that you can make the parcel invisible. Now turn visibility back on.
  11. Click the radio button next to the parcels layer, and then turn off visibility on layer0. Note that the Parcel is still visible. Layer0 is special that way.

Punching the radio button next to a layer makes it the Active Layer. The active layer is where the objects you draw will be placed. It is possible to place primitive objects in any layer you want, and then to group them and to put these groups in other layers. This capability is useful in some situations, but more often than not can cause a lot of serious confusion. If a group is on layer and its primitive objects are on any layer other than Layer0, you will find that turning layers on and off will cause odd pieces of youre model to disappear seemingly at random. If you find this happening, you should go inside of the group in question and select all of the primitive objects and move them to layer zero. To avoid this confusion ALWAYS LEAVE LAYER ZERO AS YOUR ACTIVE LAYER!. Other layers are for storing grouped geometry.


Putting things where you Want with Construction Lines

The zoning ordinance states that every parcel needs to have 10 feet of open space at the back. This will control where we put our building. We can establish this 10 foot offset using the Tape Measure Tool and the Value Control Box to pull an offset from the back line of the parcel exactly 10' into the parcel. The dashed line that is created is called a Construction Line. The construction line can be used as a guiode now to control the placement of the building. Note that you couls also pull lines out from the or the sides of the parcel. You can also create similar guides based on radiuses and angles if you would rather control position that way.


Becoming Comfortable with Locating your Cursor and Orientation in your Model

In all 3d modeling packages, controlling the location of your cursor and the orientation of your model is critical to being able to represent the forms that are in your imagination. The challenge is that our computer screen is two dimensional, and yet we need to be able to place geometry in a 3d space. IN some modeling software packages, you control the placement of your drawing tools by constraining the mouse movement to specific planes or by setting up constraints to movement with snap settings that are adjusted according to layers and types of geometry. SketchUp, on the other hand, is designed so that the placement of your cursor in 3d space can be controlled without taking your hand off of the mouse -- without frequent adjustment of a snap settings dialog. SketchUp's dependence on inferences, as opposed to explicit (and complex) menus of snap options and reference planes is a distinction that makes SketchUp a quick productivity tool with which users can become very quick and fluent. TO make the most of it, you have to get a sense of how Sketchup takes inferences from your mouse movements. It is absolutely essential to use Sketchup with a Scroll Wheel mouse!

The cursor in SketchUp tends to jump to nearby vertices, edges and faces. These inferences can help us and also be very frustrating if our cursor jumps to locations that aren't where we want our cursor or new geometry to snap. As it happens, these snaps are much easier to deal with when we are zoomed in close to where we want to stick a point. zoomed out. For this reason you often have to zoom in close to locate one end of a line, and then in the midst of drawing, zoom out with the middle scroll wheel, perhaps shifting the center of the view by double-clicking the scroll wheel to get to where you want to place the other end of the line, where you would zoom in again to place the other end exactly where you want it. Learning to navigate with the middle scoll wheel while editing is an essential sketchup skill!

The fact that other geometry that is visible in the model can be frustrating, but you should realize that you can control what objects are attracting your mouse by reorienting your view so that the area behind your work is not filled with detail. Of course it is also good to have your model organized so that you can selectively make detail disappear by turning off layers or hiding objects.

Sketchup also uses the axes in the model to help to infer the direction of our movements in 3-space. For example, if we want to create a vertical line, we can drag in the direction of the Blue Axis. This can be confounded if there is a lot of detail behind the cursor that is attracting inferences. So, if we want to draw an inference from the blue axis, it if helpful to change the oriantation of the model by orbiting to an elevation view so that we can pull our line up into the sky without anything behind it. We still may have problems if the orientation of our model in our window is such that the blue and green axes are in-line with eachother. Therefore, in order to comfortably control the movement of our cursor in Sketchup we must be aware of how the orientation of our model may at times enhance or confound Sketchup's Inference Engine.


Adding Trees and Cars

The way the building is sited on the lot makes a difference in terms of the way that people can use and move around the site. TO makes these relationships clearer lets we add some items to the model for scale. Sketchup makes this very easy. The Components Window has many little models that we can easily drag into the model. There are vast libraries of this 3d-clip-art that we can download from the sketchup site. Using these components will give us an opportunity to learn how to use the Rotate Tool.

  1. Choose Window>Components to open the components window.
  2. Click the little down arrow underneath the Edit tab to shoose the Components Sampler.
  3. Drag a car into the street infront of your building. Choose the Rotate Tool to click a corner of the car's selection box, then click another corner, and rotate the car until it is aligned with the street.
  4. Move the car to the curb.
  5. Use the Rotate Tool to rotate the to an apropriate orientation to the lot.
  6. Drag a picnic table into the park behind the building. Perhaps put a person in the park and across the street. Landscape and put your tree and picnic table on this layer.

Layers Control the Thematic Appearance of the Model

Now that the grouped objects in your model are organized i layers, you have a certain amount of control over which objects are visible. This is useful for several reasons. As your model becomes more complicated, Layers allow you to turn off classes of objects that you don't want in the way when you are trying to control where you are creating stuff. The ability to turn off layers allows you to control what objects are being selected when you drag a box around things.

The Outliner Window and the Hierarchal organization of your Model

Now lets look at another way of organizing your model. If you choose Window->Outliner you will see that the groups we have made and the trees and cars and the sketchup guy are all identified here./ Selecting a group from the outliner window selects that group in the model. If you turn layers on and off, this also affects what groups appear in the outliner. Next we are going to observe how the Outliner Window lets us create a hierarchal structure for our geometry that is very useful.

References

Create a Development Scheme

A Property is a Parcel of Land plus the improvements: buildings and landscaping elements that sit on that parcel.

  1. In the outliner window select your building, and your parcel and your tree and your picnic table and group them. Now you have a group of groups!
  2. You can call this group 39 Tileston Street.
  3. Back in the sketchup window, grab the Move Tool to select one corner of the parcel.
  4. Holding the Control key down causes a plus sign to appear next to the move tool, which means that you will be moving a copy of the object.
  5. Move a copy of 39Tileston across from the first one, as if there was a street in the middle.
  6. Note in the outline window that you have two copies of 39 Tileston. You can right-click the new one and rename it 38 Tileston.

What we have created is a Object Schema for a property. And we now have two instances of that schema that have a similar arrangement of elements. Now we can use the Outliner window to go into these hierarchal objects and select the tree that is associated with 39 Tileston. We can select and lock all of the elements of 38 Tileston by locking the group. This arrangement demonstrates how grouping creates a Hierarchal Orgaization of the model. 38 Tileson and 39 Tileston are independent and so we can modify the shape of the buildings their piosition on the parcels and the position and number of trees and picnic tables to experiment with the massing and siting of buildings might create a different feel for the street.

Concluding Remarks and Scenes

I hope that this tutorial has conveyed the two fundamental means that Sketchup provides for organizing geometry: layers and groups, and how layers and groups relate to each-other. Layers are a way for you to organize your model thematically. Groups provide a means of organizing your model hierarchically. The Outliner window provides a way of accessing elements of your model through its hierarchal structure. This is plenty for one tutorial session. But there is one more aspect of sketchup model organization that we should discuss soon: Once your model has become complicated, you may want to be able to store combinations of layer settings and the status hidden groups. This is accomplished by a third and final way of organizing a sketchup model -- Scenes. Perhaps we will cover this in the next tutorial!