Geographic Information Systems (+/-)
Data Resources (+/-)
Data Handling (+/-)
Effective Cartography (+/-)
Analytic Techniques (+/-)
Topographic Modeling in 3D (+/-)
Metropolitan Scale 4-D Models (+/-)
GeoWeb (+/-)
  Computer Resources GIS Manual  

Designing Landform with Contours, Surfaces and Images

This tutorial provides a set of procedures through which landform is modeled and manipulated with contours; contours interpolated to surfaces and surfaces colored with images. These procedures should provide new levels of efficiency in exploring ideas about landform, and new effectiveness in sharing our ideas with our colleagues, clients and critics.

Roll your mouse over highlighted text for illustration

Three-Dimensional modeling software provides techniques for using easy-to-get terrain data to model existing conditions and to easily create alternate scenarios that can be easily compared visually, or analyzed numerically.

The basic outline of the tutorial includes:
  1. Consider our modeling goals
  2. Practice with tha basic techniques of site terrain modeling in FormZ.
  3. Learn to alter and create new contours, and to use them to generate alternative surfaces.
  4. Downolad and assess a site terrain dataset that includes underlay images, contours, existing site and context models.
  5. Evaluate the modeling result

Consider your Modeling Goals

Before undertaking any modeling project, it is wise to pause and consider the objectives. This will help to plan a course of work that is focused on the critical details of the project, and avoid spending too much time modeling things that are of no consequense. Knowing the goals in advance will also provide a benchmark against which our work can be evaluated.

The goals of our current project is work out scenarios for using 500,000 cubic yards of fill on a waterfront site near Providence Rhode Island. We will be working with several other designers on this project, and so we will need to use an agreed-upon coordinate system that will allow us to use a common base dataset, and permit our client to easily compare the various scenarios generated. It is likely that the new model of site terrain will be used as the basis for the genration of elaborated rough concceptual site models.

Practice with the basic terrain modeling techniques in FormZ.

The terrain modeling functions of FormZ are simple, yet there are many gotchas that will frustrate you until you have practiced. These steps, and tips for organizing your work will help you get into the groove.

Make a Contour Map and Genrate a Surface

  1. Open a new FormZ project, and set the Options->Working Units to 'City'
  2. Make a new layer named site_1, and make it active.
  3. Make a 2-dimensional square approximately 200 feet on a side. this represents the extent of your site model. Name this new object, "site_bdy."
  4. If its not already, set your view to 'Top'
  5. Now use the Vector Line create tool, Mtool:3b,3 to make a 2-D contour line at elevation zero, and make a contour that nips off the south-east corner (about a quarter) of your site boundary. see picture. Your contour must cross the site boundary at both ends. name this new contour 'Contour 0.' This contour is our shoreline it will have water to the south-east and nand to the north west.
  6. Make a new contour out in the ocean and use a relative move to move it down to -30' in the z axis. name this "contour-30."
  7. Make a new 10' contour paralell with your shortline about 100 feet to the northwest. This is the top of the bank.
  8. Make another 10foot contour just inside the west and north boundaries of the site.
  9. Select all four contours and use the Group tool, M-tool:9b,3. Name the new group 'Contours'.
  10. Move your site boundary down to -35' to be 5 feet below the bottom of your model. (hint: use a relative movement for this.)
  11. Use the derived 3d extrusion tool, Mtool:5a,4 to extrude a base for your site model, by 5 feet. Call this new object site_base.
  12. Now select all of the contours by selecting the contours group from the objects palette.
  13. Click the Terrain Model Tool, M-Tool:5a,10 and take a look at the tool options. DOn't change them this time.
  14. The prompts palette is asking you to pick a face, so set your pick- mode to face, M-Tool:4a,2 then click two edges of your site base.
  15. A new mesh object should be created. Name it Site_Model_1.
  16. Try rotating your view and setting your display to RenderZone

Analyze your Model

The cool thing about working with a solid modeling tool like FormZ is that once you figure out how to turn your contours into a model, you can easily analyze the model to learn things such as its volume.

Query the Volume of your Site Model

  1. Pick your new Site Model using the Object Palette.
  2. Use the Query Objects Tool M-Tool:12b,1 to return statistics about the new solid.
  3. The Volume field may be blank at first, but click on the CuFt pulldown, and the volume will update.
  4. If the volume is negative, this is due to some glitch with FormZ. YOu can fix it by leaving Site Model 1 selected and using the Reverse Direction Tool M-Tool:11b,2 to reverse its direction. Then Query it again. Make a note of the initial volume of your site.

Make a Copy of Your Model Components for Editing

We want to alter our contours to experiment with adding or taking away fill from the site. But we should keep our initial representation of the site condition for comparison.

  • Use the Object Palette Dialog (accessed by clicking on the word, Name at the top of the Objects palette, to make copies of the contours group and the Site_Base.
  • Maka a new layer named "Site 2" and uuse the switch layer tool, M-Tool:14b,3 to move your new copies of your contours and site base to your new layer.

Modify your Contours and Measure the Volume Again

Now comes the fun part. We now can spin out lots of scenarios of spreading fill out around the site, and easily measure the consequuenses.

Modifying Terrain

  • Hold down Ctrl-Shift, and select Wire Frame from the Display menu. This should bring up the Wireframe options dialog.
  • Under Interactive check the box next to 'Points'. this will cause FormZ to show us where the individual points are in out lines so that we can move them.
  • Now change your Topological pick mode to 'Point' M-Tool:4a,1 and use the move tool to scoot your coast line out a little bit.
  • Regenerate the model and query the result.
  • Try making a cone-shaped pile of fill in the middle of the site.

Experiment with Various Terrain Modeling and Display Options

The options you choose for various terrain types can make a difference in the surfaces that result from the same contour data. Meshes are very efficient, but traingulated terrain models are often more faithful to the contours, as seen in the images below. ALso when making images to show your models to others, it can be useful to set the display properties of your surface objects to show the wire-frame when rendering.

Downolad and assess a shared site terrain dataset

Each member of our design team will start with the same base model. This model provides the basic lay of the land as interpreted from an orthophotograph and a georeferenced, scanned topographical map. Because we anticipate a lot of regrading of the site, our initial site model is not very detailed. This will simplify the work for quickly generating conceptual alternatives. Anticipating the need to use our models with others, the initial reference frame for the model is Rhode Island's State Plane Coordinate System, Built on the North American Datum of 1983, with units of Feet.

Right-click here to download the prepared site model. Open the zip archive and extract it to an empty working directory on your C:\temp directory.

Our shared site model archive contains two images and a formZ project, and a readme file that serves as a table of contents for the data archive.

Our formZ project has a group layer named contours, three models: 'Left Context', 'Right Context' and 'Site' and a polygon named 'Water.' Observe that the water is a plane with its elevation set at zero. We can simulate the tidal flux by moving the water 2 feet up and two feet down.

Make Copies of the central site extent clip, and the Contours

To experiment with a terrain scenario we should start by making a copy of the site pad and the contours.

  1. Set your display to Wire-Frame.
  2. Make a new layer called Site Scenario 1
  3. Set your Edit->Duplication Offset to zero for x, y, and z.
  4. Use the objects palette to select the object named Site Clip this is the original rectangular extrusion used to make the site model. Its base is set at -35' and it has been extruded to 5' tall.
  5. Use Edit->Duplicate to make a copy of this object.
  6. Deselect everything with Ctrl-Tab then find the new object named Site Clip Copy in the objects palette, and select it.
  7. Select your new layer, Site Scenario 1 and use the change layer tool, Mtool:14b,3 to put your new pad copy onto your new layer.
  8. Open your Objects Palette Options dialog by clicking on the word, Name in the Objects palette.
  9. Make a copy of the grouped object, Contours.
  10. Use the change layer tool to move your contour copies to your new layer.

YOu are now ready to begin experimenting with fills and cuts on your site

For your information, I have found that setting the tool options for the terrain model tool to Tirangulated Contour Model with Triangulate Non-Sloping produces the most faithful models. Setting your RenderZone Options to Raytracing and Super Sampling to High makes for the best images, but takes the longest.